Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
septard
Posts: 29
Registered: ‎11-22-2012
My Device: Blackberry Bold 9700

Error when package and signing my application via Ripple emulator

i got this error when i was packaging and signing my application in ripple... 

Oh Snap! Build request failed with message: [ERROR] C:\Users\Septa\AppData\Local\Temp\widgetGen.16460807691353595655102.tmp\MyRelationLoc.jad (The system cannot find the file specified)

some one knows why is this happened?

Please use plain text.
BlackBerry Development Advisor
oros
Posts: 1,557
Registered: ‎04-12-2010
My Device: BlackBerry Z10

Re: Error when package and signing my application via Ripple emulator

Hi there,

 

Can you please confirm:

  • The Platform that is selected under the Platforms panel on the right side of the screen.
  • The settings you have specified under the Build > Settings... dialog?

Also, can you please copy/paste the entire log of the build attempt? There may be something that occurred earlier that prevented the packaging from successfully completing.

 

Finaly, can you please confirm your OS, version, and format (32-bit or 64-bit)?


Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
Please use plain text.
Contributor
septard
Posts: 29
Registered: ‎11-22-2012
My Device: Blackberry Bold 9700

Re: Error when package and signing my application via Ripple emulator

[ Edited ]
  • The platform is WebWorks 2.0.0
  • Setting :
  1. SDK Path : C:\Program Files (x86)\Research In Motion\BlackBerry WebWorks SDK 2.3.1.5
  2. Project root : C:\AppServ\www\MyApp
  3. Archive Name :MyRelationLoc
  4. E:\BackUpTA\pack3
  • Log :Log 1
  • Log 2

  • i'm using Windows 7 Ultimate 64 bit
Please use plain text.
Contributor
septard
Posts: 29
Registered: ‎11-22-2012
My Device: Blackberry Bold 9700

Re: Error when package and signing my application via Ripple emulator

now i get this new error ~_~a

oh no

Please use plain text.
BlackBerry Development Advisor
oros
Posts: 1,557
Registered: ‎04-12-2010
My Device: BlackBerry Z10

Re: Error when package and signing my application via Ripple emulator

One more check, can you please navigate to the following folders, and confirm all the JRE and JDK versions that show up:

  1. C:\Program Files\Java
  2. C:\Program Files (x86)\Java

Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
Please use plain text.
Contributor
septard
Posts: 29
Registered: ‎11-22-2012
My Device: Blackberry Bold 9700

Re: Error when package and signing my application via Ripple emulator

okay sir... 

jre6 and jdk1.6.0_29

thx for your help oros :smileyhappy:

Please use plain text.
BlackBerry Development Advisor
oros
Posts: 1,557
Registered: ‎04-12-2010
My Device: BlackBerry Z10

Re: Error when package and signing my application via Ripple emulator

Just to confirm, is that under the regular Java folder or the x86 folder? (Wondering whether it is 32-bit or 64-bit.)


Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
Please use plain text.
Contributor
septard
Posts: 29
Registered: ‎11-22-2012
My Device: Blackberry Bold 9700

under x86 folder sir...

[ Edited ]

under x86 folder sir...

c:\Program Files (x86)\Java\

 

 

Please use plain text.
BlackBerry Development Advisor
oros
Posts: 1,557
Registered: ‎04-12-2010
My Device: BlackBerry Z10

Re: under x86 folder sir...

So far everything is looking as it should. A few other thoughts:

1) Do you have UAC enabled? If so, can you please disable UAC, reset your PC, and attempt the packaging?

2) Do you see the same error when packaging from the command-line directly?

3) Can you please try from the command-line but run Command Prompt as an Administrator?

 

Let me know if you have any questions about the above steps.

 

Apologies that I don't have an immediate fix for this. The error seems to indicate that the JAD file isn't being created, and now that we've ruled out the JDK installation, it's starting to look like an environmental issue.


Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
Please use plain text.
Contributor
septard
Posts: 29
Registered: ‎11-22-2012
My Device: Blackberry Bold 9700

Re: under x86 folder sir...

[ Edited ]

okay sir i'll check for that

before that i need you to take a look at my config.xml... are there something wrong with this so i can't sign my app ??? because when trying 2nd packaging and signing, the signing was failed...

sorry for taking your time,,, but thank you anyway :smileyhappy:

<?xml version="1.0" encoding="UTF-8"?>

<widget xmlns="http://www.w3.org/ns/widgets"
xmlns:rim="http://www.blackberry.com/ns/widgets"
version="1.0.0.2">

<name>MyRelationLoc</name>
<author>SeptaRD</author>
<description>
My Relation Loc BlackBerry WebWorks Application
</description>

<license href="http://opensource.org/licenses/alphabetical">
</license>

<!-- WebWorks API -->
<feature id="blackberry.system" required="true" version="1.0.0.0" />
<feature id="blackberry.find" required="true" version="1.0.0.0" />
<feature id="blackberry.identity" required="true" version="1.0.0.0" />
<feature id="blackberry.pim.Address" required="true" version="1.0.0.0" />
<feature id="blackberry.pim.Contact" required="true" version="1.0.0.0" />
<feature id="blackberry.io.file" required="true" version="1.0.0.0" />
<feature id="blackberry.utils" required="true" version="1.0.0.0" />
<feature id="blackberry.io.dir" required="true" version="1.0.0.0" />
<feature id="blackberry.app" required="true" version="1.0.0.0" />
<feature id="blackberry.app.event" required="true" version="1.0.0.0" />
<feature id="blackberry.ui.menu" />
<feature id="blackberry.ui.dialog" />

<access subdomains="true" uri="file:///store/home" />
<access subdomains="true" uri="file:///SDCard" />

<!-- Expose access to all URIs, including the file and http protocols -->
<access subdomains="true" uri="*"/>
<access subdomains="true" uri="http://gstatic.com"/>
<access subdomains="true" uri="http://google.com"/>
<access subdomains="true" uri="http://googleapis.com"/>

<icon rim:hover="false" src="resources/iconTA.png" />
<icon rim:hover="true" src="resources/iconTA-hover.png" />

<rim:loadingScreen backgroundColor="#000000"
foregroundImage="resources/loading-screen.png"
onFirstLaunch="true">
<rim:transitionEffect type="fadeOut" />
</rim:loadingScreen>
<rim:smileytongue:ermissions>
<rim:smileytongue:ermit>read_geolocation</rim:smileytongue:ermit>
</rim:smileytongue:ermissions>
<rim:navigation mode="focus" />
<content src="index.html" />

</widget>




Please use plain text.