Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
asiayeah
Posts: 118
Registered: ‎11-05-2011
My Device: Z10, Bold 9900
My Carrier: Smartone

How to update my Bar Manifest to the correct minimum OS?

[ Edited ]

Hi,

 

I am trying to submit a new WebWorks PlayBook app to BB World. When I chose the Min. OS, I got the following message:

 

"You are about to overwrite the definition from the Bar Manifest file. This may cause negative customer impacts. Please make sure to update your Bar Manifest to the correct minimum OS."

 

In my bar's MANIFEST.MF, it has the following line:

 

Application-Requires-System: Tablet OS/1.0.7.0

 

Question is how do we set the minimum version there? Is there a command line parameter for the WebWorks tool for PlayBook? Or a config somewhere in config.xml? 

 

I only started to get this error message recently and it could be a new check introduced in BB World recently.

 

Thanks.

 

Tony

 

Please use plain text.
Developer
matizeitune
Posts: 366
Registered: ‎07-15-2013
My Device: blackberry Z10
My Carrier: Personal

Re: How to update my Bar Manifest to the correct minimum OS?

[ Edited ]

https://developer.blackberry.com/html5/documentation/working_with_config_xml_file_1866970_11.html

here is all that con you put in your config.xml. It is the badder than cascades , in cascades the bar-descriptor is better than bbui

If you find this information useful please click like --->
@mezeitune on twitter
Please use plain text.
Developer
asiayeah
Posts: 118
Registered: ‎11-05-2011
My Device: Z10, Bold 9900
My Carrier: Smartone

Re: How to update my Bar Manifest to the correct minimum OS?

Thanks. Exactly I don't see a configuration option for setting minimum OS version required in config.xml.

 

Besides I need it for both Tablet OS (PlayBook) and BB10. Thanks.

Please use plain text.