Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
MichalKozminski
Posts: 36
Registered: ‎07-05-2012
My Device: 9900 & dev alpha
Accepted Solution

Huge icons and not working SDK

Hi,

After updating to recent SDK 1.0.2.9 then I try to deploy app I stuck on blackberry logo and then I load it with older one 1.0.1.17 I get huge elements which I attach. I use Mac OS 10.8 and everything worked for me until I upgraded os to recent  and same with SDK.  Secondly Ripple don't find my config.xml so I use this script to install : 

http://cl.ly/text/2O3L3U3O2j2r

Here is screenshot of app builded by 1.0.1.17: 

http://cl.ly/image/2g2E3i2V113o

Please use plain text.
BlackBerry Development Advisor
chadtatro
Posts: 620
Registered: ‎10-01-2009
My Device: Z10

Re: Huge icons and not working SDK

In regards to the large scaling of bbUI,  I found if you remove the <meta viewport...> tag from your index.html it will scale properlly.  I'm not sure which property is causing bbUI to scale that way yet, but it should fix it.

 

I'll have to look in to your other question a bit more.  I've packaged several apps the past couple days, and haven't had an issue with the config not being found.

Chad Tetreault | App Development Consultant | BlackBerry Developer Relations | developer.blackberry.com | @chadtatro
Please use plain text.
Contributor
MichalKozminski
Posts: 36
Registered: ‎07-05-2012
My Device: 9900 & dev alpha

Re: Huge icons and not working SDK

http://cl.ly/image/1L2G3f1m2J2C - app from my pc which is example from bbui and here app from web: 

http://cl.ly/image/2g3U2X0I2F15 I don't know why on localhost it could't find config.xml even it they are same. 

PS. localhost:8080/config.xml works

Please use plain text.
Developer
nunodonato
Posts: 313
Registered: ‎03-28-2012
My Device: Curve 9360, Playbook, BB10 Dev Alpha

Re: Huge icons and not working SDK

Just as a note, my index.html does not have the meta viewport tag and I also get this problem.

Nuno
theBBthing.wordpress.com - my BlackBerry development blog: news, tips and tutorials
bitoutsidethebox.com - re-imagining digital solutions


Please use plain text.
Developer
rorybarnes
Posts: 214
Registered: ‎01-07-2011
My Device: Bold 9900

Re: Huge icons and not working SDK

If you get the latest version 0.9.4 from the next branch it fixes the scaling issues (https://github.com/blackberry/bbUI.js/issues/352)

--
Rory (@roryboy)
Click "Accept as Solution" if post solved your original issue. Give like/thumbs up if you feel post is helpful
Please use plain text.
Contributor
MichalKozminski
Posts: 36
Registered: ‎07-05-2012
My Device: 9900 & dev alpha

Re: Huge icons and not working SDK

Now  im stuck on blackberry logo with new sdk and I have to use old one.

Please use plain text.
BlackBerry Development Advisor
cdelcol
Posts: 37
Registered: ‎01-08-2010
My Device: Various

Re: Huge icons and not working SDK

Have you actually upgraded the OS on your Dev device? There was a post yesterday with the exact same behaviour and that was the cause. The new version of the SDK will not work with the old version of the OS. It will package and deploy, and then just hang without doing anything.

Please use plain text.
BlackBerry Development Advisor
cdelcol
Posts: 37
Registered: ‎01-08-2010
My Device: Various

Re: Huge icons and not working SDK

Chad,

 

Any scaling issues are likely related to Webkit no longer supporting "target-densitydpi" attribute in the viewport tag. This change affects the latest OS release.

 

I thought there was a dev blog post talking about the change awhile back but I can't seem to locate it. Regardless, this brings us inline with other major platforms going forward.

 

Please use plain text.
Contributor
MichalKozminski
Posts: 36
Registered: ‎07-05-2012
My Device: 9900 & dev alpha

Re: Huge icons and not working SDK

Yep I have os version 10.0.9.388

Please use plain text.
Developer
nunodonato
Posts: 313
Registered: ‎03-28-2012
My Device: Curve 9360, Playbook, BB10 Dev Alpha

Re: Huge icons and not working SDK

I have the latest SDK, using the correct WebWorks file and bbUI 0.9.4, and i still get a huge display :smileysad:
Nuno
theBBthing.wordpress.com - my BlackBerry development blog: news, tips and tutorials
bitoutsidethebox.com - re-imagining digital solutions


Please use plain text.