Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Highlighted
Developer
Posts: 63
Registered: ‎10-07-2009
My Device: Not Specified
Accepted Solution

Initial-scale doesn't work

Hello, I'm building a web-app and I'm following BlackBerry_Widget_SDK-Fundamentals_Guide, that recommends:

 

<meta name="viewport" content="width=device-width,height=device-height, initial-scale=1.0" />

 

But, I'm modifying the initial-scale and the device always show the same. I tested with:

 

<meta name="viewport" content="width=480px,height=auto, initial-scale=0.5" />

<meta name="viewport" content="width=480px,height=auto, initial-scale=2.0" />

<meta name="viewport" content="initial-scale=1.5" />

<meta name="viewport" content="initial-scale=3.0" />

<meta name="viewport" content="initial-scale=2.0" />

 

And there is no way

 

Thanks

Retired
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Initial-scale doesn't work

Hi aserra, thanks for your post.

 

Although this is documented in the Widget SDK Fundamentals, I do not believe initial-scale is supported as expected by the BlackBerry browser rendering engine.  Which BlackBerry Smartphone model and handheld software version are you using?

 

Would you kindly submit this as a feature enhancement in the developer issue tracker: https://www.blackberry.com/jira/secure/Dashboard.jspa.  That way other members of the developer community can vote and provide their own input on this request.  This also helps our product management teams prioritize the addition of new features.

 

Best regards,

Adam

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
Developer
Posts: 63
Registered: ‎10-07-2009
My Device: Not Specified

Re: Initial-scale doesn't work

yes, it was my fault, I was not undestand the conceptualy:

 

initial-scale=0.0  --> default scale

initial-scale=1.0  --> 1 level of zoom

 

thanks