Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
deejayburnout
Posts: 7
Registered: ‎04-06-2013
My Device: Bold 9900 & Playbook 64GB

Issues with Hello World Demo - Cannot find Helloworld.swf????? - Please Help

Good Morning Everyone.

 

Completely new to this app designing and been trying to package the Hello World app to try it on my playbook.

 

However, i cannot get the app to be published within ripple.

 

I have a load of problems, but with trial and error and a lot of help from this forum, i have managed to fix a few of them. I am now stuck here and i have a sore head from spending hours trying to fix it.

 

Can anyone help.

 

I have took a copy of the text from the command prompt so you can see for yourself whats wrong. Its looks like it is looking for a swf file? Isn't that a shockwave file?

 

Many thanks

 

Chris

 

 

 

 

Starting in production mode.
Picard boldly goes on port 9910...
2013-04-07 03:26:04 POST /ripple/build/tablet 200
Checking output path C:/Users/crampmagnet/Desktop/Published app/
Path already exists
Running zip in C:\Users\crampmagnet\RippleSites\HelloWorld
exec - "C:\Users\crampmagnet\AppData\Local\Google\Chrome\User Data\Default\Exten
sions\cnijnnaimeaacneklcndcafbnkeicckh\0.9.14_0\services\node\node_modules\rbd/.
./../../bin/zip.exe" -r "C:\Users\crampmagnet\Desktop\Published app/HelloWorld.z
ip" *
out:   adding: config.xml
out:  (152 bytes security)
out:  (deflated 47%)
  adding: geo.js
out:  (152 bytes security)
out:  (deflated 70%)
  adding: images/
out:  (152 bytes security) (stored 0%)
  adding: images/helloWorld.png
out:  (152 bytes security)
out:  (deflated 0%)
  adding: images/icon.png
out:  (152 bytes security)
out:  (deflated 2%)
  adding: index.html
out:  (152 bytes security)
out:  (deflated 50%)
  adding: publish/ (152 bytes security) (stored 0%)
  adding: publish/HelloWorld.zip (152 bytes security)
out:  (stored 0%)
  adding: styles.css (152 bytes security) (deflated 50%)

out: [INFO]
out: Parsing command line options

out: [INFO]                     Parsing bbwp.properties
out:

out: [INFO]
out: Validating WebWorks archive

out: [INFO]                     Parsing config.xml
out:

out: [WARNING]
out: Failed to find a <feature> element

out: [INFO]
out: Populating application source

out: [INFO]                     Compiling WebWorks application

out: Error occurred during initialization of VM
Unable to load native library: Can't find dependent libraries

out: [INFO]                     Packaging the bar file

error: java.io.FileNotFoundException: C:\Users\CRAMPM~1\AppData\Local\Temp\widge
tGen.13896915801365305164330.tmp\HelloWorld.swf (The system cannot find the file
 specified)

out: [ERROR]                    Air Packager exception occurred

error:  at java.io.FileInputStream.open(Native Method)
        at java.io.FileInputStream.<init>(Unknown Source)
        at net.rim.tumbler.file.FileManager.copyFile(FileManager.java:481)
        at net.rim.tumbler.airpackager.AirPackager.run(AirPackager.java:232)
        at net.rim.tumbler.WidgetPackager.go(WidgetPackager.java:152)
        at net.rim.tumbler.WidgetPackager.main(WidgetPackager.java:77)

Done build
error response - {"code":1,"msg":"\tat java.io.FileInputStream.open(Native Metho
d)\r\n\tat java.io.FileInputStream.<init>(Unknown Source)\r\n\tat net.rim.tumble
r.file.FileManager.copyFile(FileManager.java:481)\r\n\tat net.rim.tumbler.airpac
kager.AirPackager.run(AirPackager.java:232)\r\n\tat net.rim.tumbler.WidgetPackag
er.go(WidgetPackager.java:152)\r\n\tat net.rim.tumbler.WidgetPackager.main(Widge
tPackager.java:77)\r\n","data":null}
2013-04-07 03:26:04 GET /ripple/build_status/4637 200

Developer
JRab
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: Issues with Hello World Demo - Cannot find Helloworld.swf????? - Please Help

Hey deejayburnout,

 

It looks like your path to your WebWorks SDK might be incorrect -- what does the settings panel in Ripple look like where you fill out the app location / SDK location? A screen shot would be welcome. Thanks!

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
New Contributor
deejayburnout
Posts: 7
Registered: ‎04-06-2013
My Device: Bold 9900 & Playbook 64GB

Re: Issues with Hello World Demo - Cannot find Helloworld.swf????? - Please Help

[ Edited ]

Morning JRab

 

Thanks for your reply

 

Here is a cap of the screen. the SDK path in the box is C:\Program Files (x86)\Research In Motion\BlackBerry WebWorks SDK for TabletOS 2.2.0.5

 

[IMG]http://i213.photobucket.com/albums/cc131/deejayburnout/NewBitmapImage_zpsea056b8a.jpg[/IMG]

 

 

 

 

Developer
peardox
Posts: 1,229
Registered: ‎03-20-2011
My Device: Playbook, Z10 LE, Dev Alpha B, 2x Dev Alpha C

Re: Issues with Hello World Demo - Cannot find Helloworld.swf????? - Please Help

This is a very annoying bug with the Playbook packager

 

Find your 32 bit Java install

 

It sould be something like C:\Program Files (x86)\Java\jdk1.7.0_17

 

In your environment variables sey JAVA_HOME to the correct directory

 

This will mess up BB10 and Cordova builds so rename JAVA_HOME after your PB build

 

BB10 and Cordova want the 64 bit JDK, Playbook wants the 32 bit

 

There is a better solution but that's for command line builds and takes ages to get right




Click the like button if you find my posts useful!
Developer
peardox
Posts: 1,229
Registered: ‎03-20-2011
My Device: Playbook, Z10 LE, Dev Alpha B, 2x Dev Alpha C

Re: Issues with Hello World Demo - Cannot find Helloworld.swf????? - Please Help

Oh - I should have mentioned

 

Playbook uses an AIR wrapper to stick your app in

 

Hence the swf reference

 

BB10 uses native




Click the like button if you find my posts useful!
New Contributor
deejayburnout
Posts: 7
Registered: ‎04-06-2013
My Device: Bold 9900 & Playbook 64GB

Re: Issues with Hello World Demo - Cannot find Helloworld.swf????? - Please Help

[ Edited ]

Thanks peardox for your help.

 

I am having trouble finding where these are

 

In your environment variables sey JAVA_HOME to the correct directory

 

so rename JAVA_HOME after your PB build also what would my PB build be in this case ? 

 

http://i213.photobucket.com/albums/cc131/deejayburnout/NewBitmapImage2_zpsabe22242.jpg

 

Here is my java folder if that helps

 

Cheers

 

Chris

Developer
peardox
Posts: 1,229
Registered: ‎03-20-2011
My Device: Playbook, Z10 LE, Dev Alpha B, 2x Dev Alpha C

Re: Issues with Hello World Demo - Cannot find Helloworld.swf????? - Please Help

Open windows explorer (NOT IE)

 

Right click on My Computer

 

Select Properties

 

Advanced System Settings

 

Environment Variables

 

Add a new ENV Variable and name it JAVA_HOME - value is your 32 bit SDK path




Click the like button if you find my posts useful!
Developer
peardox
Posts: 1,229
Registered: ‎03-20-2011
My Device: Playbook, Z10 LE, Dev Alpha B, 2x Dev Alpha C

Re: Issues with Hello World Demo - Cannot find Helloworld.swf????? - Please Help

Ahh - just checked your image

 

That's the right directory

 

Here's the batch file I use - called build.bat

 

set JAVA_HOME=C:\Program Files (x86)\Java\jdk1.7.0_17
..\..\bbwp %1 -g <password> -d -v -buildId %2

This lives in a directory I call bars

 

C:\Program Files (x86)\Research In Motion\BlackBerry WebWorks SDK for TabletOS 2.2.0.5\bbwp\bin\bars

 

With that setup I merely need to type

 

build.bat <app.zip> <a number>

 

The first line does JAVA_HOME

 

The second passes the app to compile and it's buildId to bbwp keeping everything in an easy to find place

 

The output is put in a bin directory

 

..\..\blackberry-tablet-sdk\bin\blackberry-deploy -installApp -device <IP of device / Sim> -password <Device password> package bin\%1.bar

The -d switch enables web inspector - DON'T use it on production builds!

 

With the -d you can open Chrome and go to

 

http://<IP>:1337

 

Note that this is Playbook - BB10 needs different stuff




Click the like button if you find my posts useful!
New Contributor
deejayburnout
Posts: 7
Registered: ‎04-06-2013
My Device: Bold 9900 & Playbook 64GB

Re: Issues with Hello World Demo - Cannot find Helloworld.swf????? - Please Help

[ Edited ]

Hi Peardox

 

I have tried what you instructed and now i am getting this in the command prompt

 

Starting in production mode.
Picard boldly goes on port 9910...
2013-04-07 17:49:50 GET /HelloWorld/index.html 200
2013-04-07 17:49:50 GET /HelloWorld/styles.css 200
2013-04-07 17:49:50 GET /HelloWorld/geo.js 200
2013-04-07 17:49:50 GET /HelloWorld/images/helloWorld.png 200
2013-04-07 17:49:50 GET /favicon.ico 404
2013-04-07 17:49:51 GET /HelloWorld/config.xml 200
2013-04-07 17:49:51 GET /HelloWorld/images/icon.png 200
2013-04-07 17:49:51 GET /HelloWorld/index.html 200
2013-04-07 17:49:51 GET /ripple/about 200
2013-04-07 17:49:51 GET /HelloWorld/styles.css 200
2013-04-07 17:49:51 GET /HelloWorld/geo.js 200
2013-04-07 17:49:51 GET /HelloWorld/images/helloWorld.png 200
2013-04-07 17:49:51 GET /favicon.ico 404
2013-04-07 17:49:54 POST /ripple/build/tablet 200
Checking output path C:/Users/crampmagnet/Desktop/Published app/
Path already exists
Running zip in C:\Users\crampmagnet\RippleSites\HelloWorld
exec - "C:\Users\crampmagnet\AppData\Local\Google\Chrome\User Data\Default\Exten
sions\cnijnnaimeaacneklcndcafbnkeicckh\0.9.14_0\services\node\node_modules\rbd/.
./../../bin/zip.exe" -r "C:\Users\crampmagnet\Desktop\Published app/HelloWorld.z
ip" *
out:   adding: config.xml
out:  (152 bytes security)
out:  (deflated 47%)
  adding: geo.js
out:  (152 bytes security) (deflated 70%)
  adding: images/ (152 bytes security) (stored 0%)
  adding: images/helloWorld.png (152 bytes security)
out:  (deflated 0%)
  adding: images/icon.png
out:  (152 bytes security)
out:  (deflated 2%)
  adding: index.html
out:  (152 bytes security) (deflated 50%)
  adding: styles.css (152 bytes security) (deflated 50%)

out: [INFO]
out: Parsing command line options

out: [INFO]
out: Parsing bbwp.properties

out: [INFO]
out: Validating WebWorks archive

out: [INFO]
out: Parsing config.xml

out: [WARNING]
out: Failed to find a <feature> element

out: [INFO]
out: Populating application source

out: [INFO]                     Compiling WebWorks application

2013-04-07 17:49:55 GET /ripple/build_status/4179 200
out: Error: unable to load SWC ._asc-support.swc: C:\Program Files (x86)\Researc
h In Motion\BlackBerry WebWorks SDK for TabletOS 2.2.0.5\bbwp\blackberry-tablet-
sdk\frameworks\libs\._asc-support.swc is not a SWC file.

Loading configuration file C:\Program Files (x86)\Research In Motion\BlackBerry
WebWorks SDK for TabletOS 2.2.0.5\bbwp\blackberry-tablet-sdk\frameworks\air-conf
ig.xml

out: [INFO]                     Packaging the bar file

2013-04-07 17:49:55 GET /ripple/build_status/4179 200
error: java.io.FileNotFoundException: C:\Users\CRAMPM~1\AppData\Local\Temp\widge
tGen.17020722401365356994747.tmp\HelloWorld.swf (The system cannot find the file
 specified)

out: [ERROR]                    Air Packager exception occurred

error:  at java.io.FileInputStream.open(Native Method)
        at java.io.FileInputStream.<init>(Unknown Source)
        at net.rim.tumbler.file.FileManager.copyFile(FileManager.java:481)
        at net.rim.tumbler.airpackager.AirPackager.run(AirPackager.java:232)
        at net.rim.tumbler.WidgetPackager.go(WidgetPackager.java:152)
        at net.rim.tumbler.WidgetPackager.main(WidgetPackager.java:77)

Done build
error response - {"code":1,"msg":"\tat java.io.FileInputStream.open(Native Metho
d)\r\n\tat java.io.FileInputStream.<init>(Unknown Source)\r\n\tat net.rim.tumble
r.file.FileManager.copyFile(FileManager.java:481)\r\n\tat net.rim.tumbler.airpac
kager.AirPackager.run(AirPackager.java:232)\r\n\tat net.rim.tumbler.WidgetPackag
er.go(WidgetPackager.java:152)\r\n\tat net.rim.tumbler.WidgetPackager.main(Widge
tPackager.java:77)\r\n unable to load SWC ._asc-support.swc: C:\\Program Files (
x86)\\Research In Motion\\BlackBerry WebWorks SDK for TabletOS 2.2.0.5\\bbwp\\bl
ackberry-tablet-sdk\\frameworks\\libs\\._asc-support.swc is not a SWC file.\r\n\
r\nLoading configuration file C:\\Program Files (x86)\\Research In Motion\\Black
Berry WebWorks SDK for TabletOS 2.2.0.5\\bbwp\\blackberry-tablet-sdk\\frameworks
\\air-config.xml\r\n","data":null}
2013-04-07 17:49:56 GET /ripple/build_status/4179 200

 

Still not having much luck at all.

 

Could there be and issue with RIpple. I am using version 0.9.14 that i downloaded from the blackberry webworks page. Is there other versions of it?

 

 

Thanks for all your help

 

 

New Contributor
deejayburnout
Posts: 7
Registered: ‎04-06-2013
My Device: Bold 9900 & Playbook 64GB

Re: Issues with Hello World Demo - Cannot find Helloworld.swf????? - Please Help

[ Edited ]

Been fiddling about with the installation and i cannot find my adobe air installation folder even though my PC says that it is installed.

 

Getting really frustrated with this now.

 

Found a newer version of Ripple in the chrome store and that doesnt even work. The deploy service will not start.

 

Even more frustrated now.

 

I think this might be my issue, even though the file is there in the folder.


2013-04-08 10:01:51 GET /ripple/build_status/8378 200
out: Error: unable to load SWC ._asc-support.swc: C:\Program Files (x86)\Researc
h In Motion\BlackBerry WebWorks SDK for TabletOS 2.2.0.5\bbwp\blackberry-tablet-
sdk\frameworks\libs\._asc-support.swc is not a SWC file.