Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
Posts: 3
Registered: ‎12-07-2009
My Device: Not Specified

JVM Error 104 Uncaught:RuntimeException, Error starting HelloWorld Widget: Module not found

Hi,

 

I tried the Beta 2 widget sample on 9000 Simulator, and got above error. Can any one help please? Thanks.

 

yur_au

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: JVM Error 104 Uncaught:RuntimeException, Error starting HelloWorld Widget: Module not found

Which version of the 5.0 operating system is the Bold 9000 simulator running?

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
New Developer
Posts: 3
Registered: ‎12-07-2009
My Device: Not Specified

Re: JVM Error 104 Uncaught:RuntimeException, Error starting HelloWorld Widget: Module not found

Hi Tim,

 

It's running on OS4.6. There's no higher OS for 9000 simulator download available. Is there a way to upgrade? My OS is XP SP3, 32 bit.

 

Thanks.

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: JVM Error 104 Uncaught:RuntimeException, Error starting HelloWorld Widget: Module not found

That would be the issue..

 

BlackBerry Widgets require the 5.0 operating system where the simulator that you have is 4.6.  

 

Unfortunately there currently isn't an available Bold 9000 simulator with the v5.0 operating system on it.

 

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
New Developer
Posts: 3
Registered: ‎12-07-2009
My Device: Not Specified

Re: JVM Error 104 Uncaught:RuntimeException, Error starting HelloWorld Widget: Module not found

Well, thanks Tim. Good to know.

Developer
Posts: 36
Registered: ‎01-20-2010
My Device: 8520

Re: JVM Error 104 Uncaught:RuntimeException, Error starting HelloWorld Widget: Module not found

[ Edited ]

i have this problem too.

my ecplise widgets work only in 5.0

 

tneil say:

That would be the issue..

 

BlackBerry Widgets require the 5.0 operating system where the simulator that you have is 4.6.  

 

Unfortunately there currently isn't an available Bold 9000 simulator with the v5.0 operating system on it.

 

But blackberry website say:

 

http://na.blackberry.com/eng/developers/browserdev/eclipse.jsp

Note: The minimum OS versions to target for the BlackBerry Web Development Plug-in for Eclipse are v4.6.0.212, v4.6.1.132 and v4.7.0.80.

 

Widgets can be used or 4.6 or not?

 

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: JVM Error 104 Uncaught:RuntimeException, Error starting HelloWorld Widget: Module not found

Widgets will only work on OS 5.0.  The Web Plug-in tooling supports both the building of Widgets and debugging websites.  Debugging website functionality is supported starting with OS 4.6

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Developer
Posts: 36
Registered: ‎01-20-2010
My Device: 8520

Re: JVM Error 104 Uncaught:RuntimeException, Error starting HelloWorld Widget: Module not found

thnak you tneil for your answer.

i have another problem regarding widgets.

 

external links used in widgets opening page but no image there! (srry about my english)

page opens, but the images do not appear. Here's an example!

 


Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: JVM Error 104 Uncaught:RuntimeException, Error starting HelloWorld Widget: Module not found

Do the images come from a different domain?

 

If the page has images in it that are coming from a different domain, you must specify the origin of the content you wish to bring into your widget.

 

You can use "*" in your <access> elements but you will not be able to declare <feature> elements for the "*".  For any origin you want to have access to BlackBerry APIs you must explicitly declare the domain.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Developer
Posts: 36
Registered: ‎01-20-2010
My Device: 8520

Re: JVM Error 104 Uncaught:RuntimeException, Error starting HelloWorld Widget: Module not found

[ Edited ]

working. thank you.