Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
hbrilleman
Posts: 2
Registered: ‎07-19-2011
My Device: Torch 9800 simulator

Java Eclipse Blackberry webworks plugin - Torch9800 simulator

Hi, I created a webworks Blackberry project on Eclipse. When running the Torch 9800 simulator via Eclipse, it does start the simulator, but does not connect to the internet via the browser.The java log does display all the time (does not disappear), and the Eclipse console issues a message -  'CRIT Olympia::smileytongue:latform::File: error 2 calling open(/media/mmc/BlackBerry/system/appdata/rim/webstorage/net_rim_bb_browser_daemon/+++'   -  and on the simulator it issues a message 'Unable to connect to the internet, please try again later'.

 

When running the Curve 9700 simulator(via my project on Eclipse), I have no problem accessing the internet via the browser. I have been searching around on the blogs, but can't find anything that solves my problem.

 

I need to use the 9800 simulator, as the OS runs on version 6, which I need to run my SAP BSP application on.

 

Any help will be much appreciated.

 

Greetings,

 

Hans.

 

Retired
jeffheifetz
Posts: 518
Registered: ‎07-18-2011
My Device: Bold

Re: Java Eclipse Blackberry webworks plugin - Torch9800 simulator

Hi hbrilleman,

 

Try to clean the simulator using the clean.bat file located in the simulator directory and try again. Make sure that you have the MDS simulator running in the background as well.



1.Please resolve your thread by clicking the "Accept as Solution" button below the post which solved your problem!
2. If any post helps you please click the button below the post(s)
New Contributor
hbrilleman
Posts: 2
Registered: ‎07-19-2011
My Device: Torch 9800 simulator

Re: Java Eclipse Blackberry webworks plugin - Torch9800 simulator

Hi Hifetz,

 

many thanks for the reply. I tried your suggestion of running CLEAN.BAT  in combination with re-installing the Blackberry plug-in outside of the 'Program Files' path and it now works (although I still find it to be very unstable, especially for the SAP BSP to work). Next, I tried to install the signing keys - (the .CSI  and .CSJ files) via Eclipse, but everytime I try, I receive the same error - 'SERVER UNAVAILABLE AT THIS TIME'. There is no problem with the internet connectivity, so I am not sure which Server it is complaining about.

 

Any suggestions will be much appreciated.

 

Many thanks.