Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
MightyQ
Posts: 3
Registered: ‎02-03-2010
My Device: Tour
My Carrier: Verizon

Missing Module

[ Edited ]

Hi, I am new to Blackberry Widget API development and I've just created my first "Hello World" application.  I am able test sucessfully on the simulator through Eclipse.  However, when I try to deploy the application, I get the following error:

 

Additional reconciliation information  
 The module net_rim_bb_web_jse_api is missing.  
 The module net_rim_networkapi is missing. 

 

If someone can point out the right direction, I would greatly appreciate it. Thanks.

 

Please use plain text.
BlackBerry Development Advisor
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: Missing Module

Hi There,

 

What version of operating system do you have on your device?  BlackBerry widgets require a v5.0 operating system to work.

 

Also, you must acquire a code signing key and sign your application before deploying it onto a physical device.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
New Developer
MightyQ
Posts: 3
Registered: ‎02-03-2010
My Device: Tour
My Carrier: Verizon

Re: Missing Module

Hmm that explains it. I did not know v5.0 is out already.  I have v4.7.1.61 on the blackberry.

 

Please use plain text.
BlackBerry Development Advisor
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: Missing Module

Yeah the 5.0 OS started hitting the streets with the launch of Storm 2 and has been on all the new devices released since then.  It has also been released on many of the in-market smartphones prior to Storm 2.

 

The list of in-market smartphones that will support the 5.0 OS are provided in the following article:

http://www.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB17984

 

If your device is in the list contained in the above article, you can contact your wireless provider to see if they have the 5.0 download available for your smartphone.

 

Cheers

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
New Member
Ulterior_Motive
Posts: 1
Registered: ‎04-29-2011
My Device: Bold 9000
My Carrier: 3

Re: Missing Module

I am unable to update my device software to obtain these modules.

I have a Bold 9000 which is in the list of devices that can get V5.0.

Please use plain text.