Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
GuntherHan
Posts: 4
Registered: ‎05-11-2010
My Device: BlackBerry Tour

Re: Module attempts to access a secure API - even after code signing

Tim,

    Thank you for the quick response.

    The version of BlackBerry Web Plugin - Widget Development is 2.0.1.10.

    My widget uses XMLHTTPRequest to send some data to a URL, and the resturned data is parsed and used to create appointments in Calendar.

    In both local and the domain my widget is accessing, these features are added:

    blackberry.pim.Appointment

    blackberry.pim.Attendee

    blackberry.pim.Contact

    blackberry.find

    blackberry.invoke

    blackberry.invoke.CalendarArguments

 

    The widget is working perfect in Simulator.

    Each time when I build the project, I am requested to provide the password for private key access, so I am guessing that bin directory has the signed code.

    I created a Winrar archive and sent it to a coworker who has a BlackBerry Tour 9630. The OS is v 5.0.0.624 ( Bundle 1061, Platform 4.2.0.285).

    The application was loaded into the device successfully.  But when my coworker tried to activated it an error message appeared:

 Error starting: Module xxxx attempts to access a secure API.

 

    Please advice.

 

    Thanks

 

 

Please use plain text.
New Contributor
GuntherHan
Posts: 4
Registered: ‎05-11-2010
My Device: BlackBerry Tour

Re: Module attempts to access a secure API - even after code signing

Tim,

    Forgot one point: I always start my VS 2008 as Administrator.

    I don't have a BlackBerry phone at my hand right now, so I have to have my widget tested by my coworker.

 

    Thanks

Please use plain text.
New Contributor
seth50k
Posts: 5
Registered: ‎05-25-2010
My Device: 8350

Re: Module attempts to access a secure API - even after code signing

Any progress on this? I'm getting the same error. My content src is basically a https API call though, is there anyway around this or a better way to do it?

 

All i'm trying to do is trigger an API on a secure website but do it via a widget.

Please use plain text.