Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
Wongadob
Posts: 40
Registered: ‎05-12-2012
My Device: 9800
My Carrier: Virgin mobile
Accepted Solution

My Chrome Ripple Extension will not package or package & Sign

I am having issues packaging my app. I have set all the directories correctly. I have double and tripple checked. Note that package and launch is not highlighted and in the settings section it cannot find any simulators even though I have the following simulators installed.

 

I use the latest Ripple extension for chrome.

 

7.0.0.540 (9860)

7.0.0.540 (9900)

 

When I try to package - I get this error message - any ideas what is wrong ?

 

Oh Snap! Build request failded with message: error
This could be due to the Build and Deploy services not running or not being installed

 

Please use plain text.
Developer
rorybarnes
Posts: 214
Registered: ‎01-07-2011
My Device: Bold 9900
My Carrier: Rogers

Re: My Chrome Ripple Extension will not package or package & Sign

Do you have the Ripple emulator extensions running as outlined in the Enable the Ripple emulator extension section of the setup doc? They are needed to build and deploy.

https://bdsc.webapps.blackberry.com/html5/documentation/ww_getting_started/Use_the_Ripple_emulator_C...
--
Rory (@roryboy)
Click "Accept as Solution" if post solved your original issue. Give like/thumbs up if you feel post is helpful
Please use plain text.
Contributor
Wongadob
Posts: 40
Registered: ‎05-12-2012
My Device: 9800
My Carrier: Virgin mobile

Re: My Chrome Ripple Extension will not package or package & Sign

I do have the ripple emulator running in chrome, I was under the impression that the stand alone version had been discontinued in favour of the chrome extension.

 

My software runs fine within the chrome extension and everything functions but the package gives the above error. I have followed the steps outline in link above, however that dir structure does not give the exe ripple-services and it you type that you get the message that it does not exist. The files in the dir as as follows

 

 Volume in drive C is OS  

Volume Serial Number is B037-AA95

 Directory of C:\Program Files\Research In Motion\Ripple 0.9.0.16\services\bin

16/05/2012  23:29    <DIR>          .

16/05/2012  23:29    <DIR>          ..

11/11/2011  21:02               174 rbd_service.bat

11/11/2011  21:02                55 rbd_service.command

11/11/2011  21:02               209 rbd_service.sh

11/11/2011  21:02           290,816 zip.exe

11/11/2011  21:02            99,275 zip.txt               

5 File(s)        390,529 bytes               

2 Dir(s)  268,971,143,168 bytes free

Please use plain text.
Developer
rorybarnes
Posts: 214
Registered: ‎01-07-2011
My Device: Bold 9900
My Carrier: Rogers

Re: My Chrome Ripple Extension will not package or package & Sign

It is a chrome extension, but requires a command line piece to do build and deploy.

 

The directory listing you showed is for Ripple 0.9.0.16. Have you checked in the Ripple 0.9.4.1 folder?

 

R

--
Rory (@roryboy)
Click "Accept as Solution" if post solved your original issue. Give like/thumbs up if you feel post is helpful
Please use plain text.
Contributor
Wongadob
Posts: 40
Registered: ‎05-12-2012
My Device: 9800
My Carrier: Virgin mobile

Re: My Chrome Ripple Extension will not package or package & Sign

OK so I had to install ripple 10 for tablets. I thought since I was only working with smartphones that the smartphone version would be sufficient. So when I installed 10 it runs but I get this error

 


Oh Snap! Build request failed with message: [ERROR] Invalid application archive - resource name is not valid(.project)

 

Any ideas?

Please use plain text.
Contributor
Wongadob
Posts: 40
Registered: ‎05-12-2012
My Device: 9800
My Carrier: Virgin mobile

Re: My Chrome Ripple Extension will not package or package & Sign

Seems most of the issues I havce experineced were due to the fact that things need to run in administrator mode.

 

Please use plain text.
Contributor
ruilima
Posts: 12
Registered: ‎11-19-2012
My Device: non-BlackBerry user
My Carrier: non-BlackBerry user

Re: My Chrome Ripple Extension will not package or package & Sign

I don't have C:\Program Files\Research In Motion\Ripple 0.9.0.16\ folder anywhere.... But I have the extension in Chrome, but no serices running error is showing up...

Please use plain text.