Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
tony902304
Posts: 8
Registered: ‎02-02-2012
My Device: Playbook

Objects appearing behind app

I am developing an app for the playbook and ever since we updated to OS 2.0 our javascript alerts and confirms as well as HTML Selects are randomly appearing behind the application. There are no errors in the console logs and it happens randomly.

 

Anyone know what might be causing this?

 

Thanks,

Tony 

New Contributor
tony902304
Posts: 8
Registered: ‎02-02-2012
My Device: Playbook

Re: Objects appearing behind app

After further testing our application, when pressing a button to open the camera using the webworks api. If the button is pressed multiple times, the camera ui opens behind the app.

all help is appreciated.
Retired
astanley
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Objects appearing behind app

That's definitely not good.  Can we reproduce this consistently?  If so, would you please log this issue here and we can get our dev team to investigate:

 

https://github.com/blackberry/WebWorks-TabletOS/issues

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
New Contributor
tony902304
Posts: 8
Registered: ‎02-02-2012
My Device: Playbook

Re: Objects appearing behind app

We are currently in the process of trying to identify the exact cause of the problem.

So far, all my test cases have not been able to reproduce the problem we are experiencing in the actual application.

We are using RequireJS, jQuery, jQTouch, Google Maps, PhoneGap (not loaded for Playbook), lawnchair and touchSwipe.

I beleived jQTouch to be the most likely cause, but the problem was still occuring after removing it.

 

I will create an issue in github when we have more information on the problem.

 

Thanks,

Tony

New Contributor
tony902304
Posts: 8
Registered: ‎02-02-2012
My Device: Playbook

Re: Objects appearing behind app

After more unsuccessful tests today, I decided to security wipe the playbook and reinstalled the app. After the security wipe was completed and the playbook set up again, I installed the app the usual way. It was working fine. Then I connected to the web inspector using chrome on my computer and tried again. The problem happened. I closed the web inspector and started the app again.. the problem happened... I deleted the app from the playbook... cleared out all my browsing history/content on my computer... installed the app and ran it and it worked fine... I reopened the app and connected using the web inspector and it works fine...

 

Our app is currently working correctly now... It seems the Web Inspector was causing the issue???

Is there anyway for the Web Inspector to affect the app? even if it is not currently connected to the app?

 

Thanks,

Tony

New Contributor
tony902304
Posts: 8
Registered: ‎02-02-2012
My Device: Playbook

Re: Objects appearing behind app

After further work on the app, the problems came back despite not having used the web inspector...

 

Thanks,

Tony

Developer
MirkoAgrati
Posts: 26
Registered: ‎10-30-2012
My Device: Z10 Limited Edition / PlayBook / BB10 Dev A-B-C / Bold 9700

Re: Objects appearing behind app

HI,
I'm experiencing the same problem with simple HTML SELECT components.

 

I've never used webinspector to test my app, so I can exclude that it was the cause.

 

Problems happen randomly:
I click the SELECT A (it contains 3 elements) -> the webworks app stop to run.
I restart the app, I click on the same previous SELECT A and now it works.

 

Sometimes the problem happens also with empty SELECT.

 

I've tryed to manage it with try/catch on click event but this doesn't catch anything because formally there's no exception.

When will be fixed?

 

Trusted Contributor
usr501
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900

Re: Objects appearing behind app

Removing 'on FirstLaunch=true' fixes the problem of popup behind screen which also mimicks the app 'freezing'

 

takem from thread:

http://supportforums.blackberry.com/t5/Web-and-WebWorks-Development/Playbook-popup-are-coming-behind...

Developer
MirkoAgrati
Posts: 26
Registered: ‎10-30-2012
My Device: Z10 Limited Edition / PlayBook / BB10 Dev A-B-C / Bold 9700

Re: Objects appearing behind app

Yeah!

 

You're right :smileyhappy:

 

PROBLEM SOLVED

Tnx.

MA