Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
neededapps
Posts: 36
Registered: ‎09-11-2012
My Device: BlackBerry 10 Dev Alpha
My Carrier: Wind Mobile
Accepted Solution

Oh Snap! Build request failed with message: [ERROR] Native Packager exception occurred

Hello, I keep coming up with the error message "Oh Snap! Build request failed with message: [ERROR] Native Packager exception occurred [ERROR] Native packager exception occurred"

 

These are screen shots of the errors below

 

 

error.PNG

 

error2.PNG

Please use plain text.
Developer
The_Anomaly
Posts: 322
Registered: ‎08-06-2012
My Device: Dev Alpha / Playbook / Curve 9300

Re: Oh Snap! Build request failed with message: [ERROR] Native Packager exception occurred

Does your config file use any paths that start with a forward slash?

 

Like (this one is right):

<icon src="images\icon_small.png" />

 These are wrong:

<icon src="\images\icon_small.png" />
<icon src="/images/icon_small.png" />

 Anything like that?

 

 

If it helped you, click like. :smileyhappy:
Please use plain text.
Developer
neededapps
Posts: 36
Registered: ‎09-11-2012
My Device: BlackBerry 10 Dev Alpha
My Carrier: Wind Mobile

Re: Oh Snap! Build request failed with message: [ERROR] Native Packager exception occurred

Yeah it uses the right way of doing the icon.  Below is my config file.

 

Capture.PNG

Please use plain text.
Developer
The_Anomaly
Posts: 322
Registered: ‎08-06-2012
My Device: Dev Alpha / Playbook / Curve 9300

Re: Oh Snap! Build request failed with message: [ERROR] Native Packager exception occurred

Try inserting at least one feature tag.

 

  <feature id="blackberry.app" />

 

If it helped you, click like. :smileyhappy:
Please use plain text.
Developer
neededapps
Posts: 36
Registered: ‎09-11-2012
My Device: BlackBerry 10 Dev Alpha
My Carrier: Wind Mobile

Re: Oh Snap! Build request failed with message: [ERROR] Native Packager exception occurred

Sorry same error still

Please use plain text.
Developer
The_Anomaly
Posts: 322
Registered: ‎08-06-2012
My Device: Dev Alpha / Playbook / Curve 9300

Re: Oh Snap! Build request failed with message: [ERROR] Native Packager exception occurred

Try taking out the space in your widget id.

If it helped you, click like. :smileyhappy:
Please use plain text.
Developer
neededapps
Posts: 36
Registered: ‎09-11-2012
My Device: BlackBerry 10 Dev Alpha
My Carrier: Wind Mobile

Re: Oh Snap! Build request failed with message: [ERROR] Native Packager exception occurred

Okay well that did something, but I am still getting the Native Packager exception occurred, but now the line before says "GET ripple/build_status/3213 200" before it said 207 200.  So it feels like I made it furthur. 

 

Any more ideas?

Please use plain text.
Developer
neededapps
Posts: 36
Registered: ‎09-11-2012
My Device: BlackBerry 10 Dev Alpha
My Carrier: Wind Mobile

Re: Oh Snap! Build request failed with message: [ERROR] Native Packager exception occurred

Also one more thing that I forgot to mention.  In the Start B&D window that pops up when running the service it will have a couple of lines that say the same thing "Get /ripple/build_status/(whatever the last bit is) then my java will open and say "would you like to run this program" so I click yes then it will pop up a few more times with that line and then java will appear again, I click yes then I get the "oh snap" message

Please use plain text.
Developer
The_Anomaly
Posts: 322
Registered: ‎08-06-2012
My Device: Dev Alpha / Playbook / Curve 9300

Re: Oh Snap! Build request failed with message: [ERROR] Native Packager exception occurred

I was going to ask about that, sounds like you're running Comodo antivirus or something - right?

 

Also, maybe I should have asked first:

1.  What version of ripple are you using?

2.  What device are you developing for?

3.  What SDK version are you using?

If it helped you, click like. :smileyhappy:
Please use plain text.
Developer
neededapps
Posts: 36
Registered: ‎09-11-2012
My Device: BlackBerry 10 Dev Alpha
My Carrier: Wind Mobile

Re: Oh Snap! Build request failed with message: [ERROR] Native Packager exception occurred

Yeah, I am currently using AVG Antivirus 

 

1. I am using Ripple 0.9.8

2.  Developing for BlackBerry 10

3. BlackBerry 10 WebWorks SDK 1.0.1.17

 

 

Please use plain text.