Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
icq782443
Posts: 22
Registered: ‎02-21-2012
My Device: Playbook torch 9800

Package ID with an underscore

I wrote an app for BB10, in my config I gave it a name with an underscore "_" such as "my_app". 

 

That worked fine for BB10 but later when I went to do a build for playbook the packager kicked up a fuss about the id being invalid because of the underscore.

 

If I take out the underscore the config the Package Id will change and BlackBerry World won't accept it as the same application.

 

Are there any work arounds for this? or should I just submit it as a separate app for Playbook OS? 

 

Thanks,

Developer
lewellyn
Posts: 110
Registered: ‎10-22-2011
My Device: PlayBook, Bold 9650, Dev Alpha A

Re: Package ID with an underscore

[ Edited ]

I'm hoping the packager for the PlayBook gets updated as well...

 

One of the bbwp changes for BB10 was that it now accepts IRIs for the widget ID. However, it naively replaces non-alphanumerics with underscores. This is impossible to use for the PlayBook at this time. What's most annoying is that I had made a suggestion many months ago that would have avoided this. *sigh*

 

See https://github.com/blackberry/BB10-Webworks-Packager/issues/134 for how I had suggested solving it. It is, however, not too late (I hope) to see bbwp get a quick update to make the Package-IDs saner! :smileyhappy:



Is there a helpful or useful post in this thread? Click the thumbs up on it so that other people can find it more easily!
Like this post too! :smileyvery-happy:
Contributor
icq782443
Posts: 22
Registered: ‎02-21-2012
My Device: Playbook torch 9800

Re: Package ID with an underscore

Yeah, looks like it also tacks on a random hash at the end of the Product id too, so in hindsight best to build for PB first then BB10. 

 

I ended up just releasing it as a new product.

 

Thanks for replying, I wasn't sure if I wasn't clear in my question or if no one had an answer.

Developer
lewellyn
Posts: 110
Registered: ‎10-22-2011
My Device: PlayBook, Bold 9650, Dev Alpha A

Re: Package ID with an underscore

[ Edited ]

The random hash is indicative that it's a debug package, not a release package. You probably don't want to be submitting that one. :smileywink:



Is there a helpful or useful post in this thread? Click the thumbs up on it so that other people can find it more easily!
Like this post too! :smileyvery-happy:
Contributor
icq782443
Posts: 22
Registered: ‎02-21-2012
My Device: Playbook torch 9800

Re: Package ID with an underscore

Nope, even with a non debug package it does too. :smileywink: So I I'll like your original response.