Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
Posts: 1,006
Registered: ‎05-22-2009
My Device: Not Specified

Packaging Error -Build request failed with message,The directory name is invalid

[ Edited ]

Hi Guys,

I am trying to pack the hello world application using Web Works,I am getting the following error,

Build request failed with message,The directory name is invalid

On inspecting it ,i am getting issue as described as below


Ripple :: Environment Warming Up (Tea. Earl Gray. Hot.)
localhost:9900/HelloWorld/config.xmlFailed to load resource: the server responded with a status of 404 (Not Found)
ripple.js:351WebWorks :: Initialization Finished (Make it so.)
localhost:9900/HelloWorld/config.xmlFailed to load resource: the server responded with a status of 404 (Not Found)

 

in the following lines

<section class="ui-widget ui-state-error ui-corner-all" id="panel-notification" style="display: block;">
                <section class="panel-notification-closebtn">X</section>
                <section id="panel-notification-text"><span class="ui-icon ui-icon-alert" style="float: left; margin-right: .3em;"></span>Oh Snap!

Build request failed with message: CreateProcessW: The directory name is invalid.
</section>
            </section>

 

 

Am i missing anything?

SDK Path - D:\Program Files\Research In Motion\BlackBerry WebWorks SDK 2.3.1.5

Project Root - E:\HelloWorld\index.html

Archive Name - HelloWorld

Output Folder- E:\packed

Can anybody help me on resolving this issue.

Regards

Rakesh Shankar.P

BlackBerry Development Advisor
Posts: 834
Registered: ‎07-15-2008
My Device: Passport
My Carrier: Bell

Re: Packaging Error -Build request failed with message,The directory name is invalid

The Project Root is supposed to be a directory, not an html file.

Tim Windsor
Open Source Technical Lead
Developer
Posts: 1,006
Registered: ‎05-22-2009
My Device: Not Specified

Re: Packaging Error -Build request failed with message,The directory name is invalid

Hi,I tried pointing to root directory as suggessted,but still i am getting same issues.

 

 

Regards

Rakesh Shankar.P

BlackBerry Development Advisor
Posts: 834
Registered: ‎07-15-2008
My Device: Passport
My Carrier: Bell

Re: Packaging Error -Build request failed with message,The directory name is invalid

The exact same issue? With all the same output?

 

Did you put E:\HelloWorld as the root, and does config.xml exist right in that directory?

Tim Windsor
Open Source Technical Lead
Developer
Posts: 1,006
Registered: ‎05-22-2009
My Device: Not Specified

Re: Packaging Error -Build request failed with message,The directory name is invalid

I am putting as root directory,what folder that i use works while i am taking the build in command prompt ,and error

 

Ripple :: Environment Warming Up (Tea. Earl Gray. Hot.)
/ripple/config.xmlFailed to load resource: the server responded with a status of 404 (Not Found)
ripple.js:351WebWorks :: Initialization Finished (Make it so.)
/ripple/config.xmlFailed to load resource: the server responded with a status of 404 (Not Found)
Developer
Posts: 1,006
Registered: ‎05-22-2009
My Device: Not Specified

Re: Packaging Error -Build request failed with message,The directory name is invalid

and in xml section i am getting the error as "Build Request failed with message:CreateProcessW: The System cannot find the file specifed"

 

 

Regards

Rakesh Shankar.P

BlackBerry Development Advisor
Posts: 834
Registered: ‎07-15-2008
My Device: Passport
My Carrier: Bell

Re: Packaging Error -Build request failed with message,The directory name is invalid

Here is a screenshot of my working config for Ripple if that will help you.

RippleBuild.png

It doesn't look like it can find your config.xml file.

 

Here is my folder root in explorer:

KitchenSinkFiles.png

Tim Windsor
Open Source Technical Lead
Developer
Posts: 1,006
Registered: ‎05-22-2009
My Device: Not Specified

Re: Packaging Error -Build request failed with message,The directory name is invalid

Hi Twindsor,I am attaching the screen shot of my ripple settings,Plz do tell me,if there are issues.

 

Issue.jpg

 

Regards

 

Rakesh Shankar.P

BlackBerry Development Advisor
Posts: 834
Registered: ‎07-15-2008
My Device: Passport
My Carrier: Bell

Re: Packaging Error -Build request failed with message,The directory name is invalid

What's in E:\RippleInput and E:\RippleOutput?

 

Are you running ripple-services?

 

Are you running the latest version of Ripple?

Tim Windsor
Open Source Technical Lead
Developer
Posts: 1,006
Registered: ‎05-22-2009
My Device: Not Specified

Re: Packaging Error -Build request failed with message,The directory name is invalid

Ripple Input,contains helloWorld zip file .and Ripple Version,that i am using is Ripple 0.9.0.16.

 

Regards

Rakesh Shankar.P