Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
leocrawf
Posts: 47
Registered: ‎06-06-2011
My Device: bolt2

Please, Please help with html5 database

Hi you all,

 

I have been trying to get a simple html5 database to  run on a simulator for a week now but no success. The code works in browser but not on emeulator. I have tried the code here and made small agjustements for testing purposes but it does not work. I am trageting os 5 and 6 phones. The example code is hosted here:

 

https://github.com/ddluk/WebWorks-Database/blob/master/index.html

 

When it runs on phone the first alert is called which means that the database initialized . However when i enter text and try to save noting happends. I can tell because i have placed an alert to tell me when this is done. When i try to retrieve/load variables nothing happends. An alert is also placed here to tell me when this is done. I was told that i need to simulate an sd card. I have tried to simulate the sd cartd by creating a mount drive on drive (c:\bbsd I am not sure if this is how it should be done.)

 

 

This is my modification: 

 

I have added this line to the header

<script type="text/javascript" src="html5_init.js" id="html5_init" ></script>

 

Added alerts to each function:

i have added an alert to every function so that they can be trigured when each function is called.

 

 






 

Please use plain text.
Contributor
leocrawf
Posts: 47
Registered: ‎06-06-2011
My Device: bolt2

Re: Please, Please help with html5 database

No one can help with this

Please use plain text.
Trusted Contributor
chicoxml
Posts: 227
Registered: ‎09-03-2010
My Device: Not Specified

Re: Please, Please help with html5 database

please can publish your code.The above code works correctly

Please use plain text.
Contributor
leocrawf
Posts: 47
Registered: ‎06-06-2011
My Device: bolt2

Re: Please, Please help with html5 database

In the process of cutting the text to post i relaized that there was an error in the code. I corrected it and it is now saving in the emulator as well as in chrome browser. My eror was this:

 

<script type="text/javascript" src="html5_init" id="html5_init" ></script>

 

I missed the .js for the source file.

Please use plain text.