Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
madmaskd
Posts: 136
Registered: ‎07-24-2012
My Device: Blackberry Z10 LE, Q10 And PlayBook
My Carrier: Vodafone

Problem Running on the Build 395620

Problem with my Game  is 99% Canvas Html5 when we are testing on the Dev alpha A and B with the Previous Build its Running fine For Hours i have tested it on Both devices, But i don't know what is going Wrong when i test on the Latest Update Build 395620 on BB Alpha Dev B .. Kindly Enlighten me on this ......... just need some info on this Its ARGENT and i will correct the setting on the other application i am developing ...

 i am using the Latest BlackBerry 10 WebWorks SDK 1.0.4.5 and updates Ripple 2 days Ago ... App is Running fine with simulator and the Previous ver of Dev Alpha A with Os ver 10.0.9.388 Build 320287 All is working Well and Fine , But when i run on the Dev Alpha B Os Ver 10.0.9.1675 Build 395620 it Game Starts 1st comes the Splash Screen then Game Starts But the Game Runs Very very slowly and After 1 min of game When the Level changes the Game Quits Automatically...

Hit Like if you find my post Use Full Thank You...
Please use plain text.
New Contributor
BB10Amit
Posts: 5
Registered: ‎08-07-2012
My Device: Blackberry 10 Dev Alpha A And PlayBook
My Carrier: vodafone

Re: Problem Running on the Build 395620

My 2 Application Starts and Exits Automatically when we run on 620 Build Any Help

 

Please use plain text.
Contributor
raakhtar
Posts: 19
Registered: ‎12-26-2010
My Device: 9800

Re: Problem Running on the Build 395620

I keep on getting the same [ERROR] Cannot sign application - failed to find signing key file: author.p12

Please use plain text.
Developer
madmaskd
Posts: 136
Registered: ‎07-24-2012
My Device: Blackberry Z10 LE, Q10 And PlayBook
My Carrier: Vodafone

Re: Problem Running on the Build 395620

u need to Set up your Signing Keys Connect to the Net install the SDK then U need to have sighning Keys Once u have Done this Type this command as Shown in Pic ........... i have Deleted my Password and the Sighning Key number Add your in the command ................... it will take 2min and you are done .......... in ripple u need to Enter the Password Sdk Path and Project Path and the Output Folder if u have Entered Right thenu can Build 

Hit Like if you find my post Use Full Thank You...
Please use plain text.
Contributor
raakhtar
Posts: 19
Registered: ‎12-26-2010
My Device: 9800

Re: Problem Running on the Build 395620

Dude thanks for your input. I already have the signing keys since Mayand have already uploaded 3 BB 10 apps on Blackberry AppWorld successful using the 1.0.3.? Webworks. It is this new webwork which has messed up everything for me. Looking for immediate help ... TIM would you be able to help.

 

I have Windows 7 64 bit machine with Java SDK version JRE _ 6 _ 38

Please use plain text.
Administrator
MSohm
Posts: 14,227
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Problem Running on the Build 395620

Make sure you copy your developer certificate (.p12 file) to the location specified in the article below and name it author.p12.

 

Backup and Restore BlackBerry Code Signing Keys

 

Older versions of the BlackBerry WebWorks SDK required the developer certificate to be in the installation directory.  Current versions reference the standard, shared directory used by all BlackBerry SDKs.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
Developer
madmaskd
Posts: 136
Registered: ‎07-24-2012
My Device: Blackberry Z10 LE, Q10 And PlayBook
My Carrier: Vodafone

Re: Problem Running on the Build 395620

i have Backup of the Author , But What About the Problem Which i have Mentioned in the Post :smileywink: :Oops: :Angel:

Hit Like if you find my post Use Full Thank You...
Please use plain text.
Contributor
gumpyboy
Posts: 42
Registered: ‎09-25-2010
My Device: Not Specified

Re: Problem Running on the Build 395620

i've the same problem like BB10Amit , Starts and Exits instantly,
i've also restored my signing keys.. still got the same problem

any solution?
Please use plain text.
Developer
madmaskd
Posts: 136
Registered: ‎07-24-2012
My Device: Blackberry Z10 LE, Q10 And PlayBook
My Carrier: Vodafone

Re: Problem Running on the Build 395620

Gimp boy i think there is some Problem with the main thread ... i think our apps need to be tuined so that Our main thread should use less CPU  pics and other things should be handled properly, 

Error must be handled properly in the application itself ..

 

;0

Hit Like if you find my post Use Full Thank You...
Please use plain text.
Administrator
MSohm
Posts: 14,227
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Problem Running on the Build 395620

Refer to this thread for information on a canvas issue that prevents content from being rendered.

 

http://supportforums.blackberry.com/t5/Web-and-WebWorks-Development/BlackBerry-10-lt-canvas-gt-Got-G...

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.