Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
jineshpb
Posts: 15
Registered: ‎04-30-2013
My Device: Z10
Accepted Solution

Problem with application submission

I am testing A webworks app on the BlackBerry 10. When the user tap the app icon, a JavaScript alert appear. 

Please tell me what will be the reason for this error

Retired
astanley
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Problem with application submission

It could be a number of reasons. Is it your application? If so, recommend using remote web inspector to test and find out if there is a runtime error.  Otherwise, I'd recommend contacting the developer and reporting the problem.

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
BlackBerry Development Advisor
oros
Posts: 1,557
Registered: ‎04-12-2010
My Device: BlackBerry Z10

Re: Problem with application submission

I'm accepting astanley's response as the solution as the error could have a wide variety of causes that depend on the implementation. If you are able to use Web Inspector to validate the error, please share it here. Otherwise reaching out to the developer is the best approach; you could even advise them to visit these forums if they are having issues tracking down the root cause.


Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
New Developer
jineshpb
Posts: 15
Registered: ‎04-30-2013
My Device: Z10

Re: Problem with application submission

Boss,

Actually I couldnt fix up the issue. there is no problem detected in the ripple emulator but when I sent it for approval from blackberry, the support team reports an error in the app stating "When I try to open the app, it showing javascript alert error message with an "OK" option to dismiss it".

Thanks in advance

Regards

 

 

 

BlackBerry Development Advisor
oros
Posts: 1,557
Registered: ‎04-12-2010
My Device: BlackBerry Z10

Re: Problem with application submission

If you're willing to send me the BAR file (eoros@blackberry.com) I could do some testing here to see if I can reproduce / track down a cause.


Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
New Developer
jineshpb
Posts: 15
Registered: ‎04-30-2013
My Device: Z10

Re: Problem with application submission

Hello, As you suggested i sent you the BAR files with the above problem, Please check your mail :smileyhappy:

BlackBerry Development Advisor
oros
Posts: 1,557
Registered: ‎04-12-2010
My Device: BlackBerry Z10

Re: Problem with application submission

Thanks, I haven't seen anything come through yet but it could just take a moment. I'll follow-up as soon as I've tested.


Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
New Developer
jineshpb
Posts: 15
Registered: ‎04-30-2013
My Device: Z10

Re: Problem with application submission

Hello Erik,

When we submitted one of our app named units converter the support team said that "when they tap the icon a white screen appears instead of launching the app". We have included the JQM , BBUI files and packaged the app using the \BlackBerry 10 WebWorks SDK 1.0.4.5,. Please specify what will be the reson for this error

New Developer
jineshpb
Posts: 15
Registered: ‎04-30-2013
My Device: Z10

Re: Problem with application submission

Hello Erik,

When we submitted one of our app named units converter the support team said that "when they tap the icon a white screen appears instead of launching the app". We have included the JQM , BBUI files and packaged the app using the \BlackBerry 10 WebWorks SDK 1.0.4.5,. Please specify what will be the reason for this error

Developer
peardox
Posts: 1,229
Registered: ‎03-20-2011
My Device: Playbook, Z10 LE, Dev Alpha B, 2x Dev Alpha C

Re: Problem with application submission

There is an obvious thing the BB guys miss here

 

This is just a guess but may help - just going on experience here

 

If you develop on different computers BBW will reject the submission

 

The reasons for this are sensible (someone stole my PC etc)

 

If this is the case then got to vendor portal and stick a reset of your keys req in (BB guys - pls supply the correct method)

 

I've been thru this scenario myself and know this to be an issue

 

Hope this helps




Click the like button if you find my posts useful!