Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
aalvarez15
Posts: 5
Registered: ‎04-06-2012
My Device: Blackberry Playbook

Problems with Ripple and Webworks, i can not use them.

Hi everybody. I need to Know if you can help me with my problem. i want to do my first app using webworks but i can not get there because i can not work properly with the tools tha RIM is giving to me. I means, i can install the ripple but when i try to run it, it appears an error message: "C:\Program Files\Research In Motion\Ripple 0.9.0.16\ QtopenGL4.dll no esta diseñado para ejecutarse en Windows o contiene un error" (notice that i am using a spanish version of windows 7). With the webworks sdk the probem is worst, it can not install at first. So, i can not run neither the ripple emulator not the webworks. I am using windows 7 64 bits (Spanish). i have installed java SE 6 (1.6.0_u31) 64 bit edition (but i have the 32 bit edition too - not installed). Maybe the problem is the language of my operating system?? i am using Windows 7 x64 spanish edition. i really need help because i want to start a project for the company I work for but i am feeling a little frustrated bcause i can not even begin with webwrks and I want to do this project using HTML5 and javascript. Can anyone tell me if there is a problem with the software that i have downloaded from blackberry developer web site?

 

PD: when I try to install the software, Install anywhere allways ask for the location where it is going to place the installer files and it stays in a loop allways asking, is that normal?

 

Ripple emulator problem: QtOpenGL4.dll is not designed to execute in Windows or has an error.

Webworks Problem: jvm.dll is not designed to execute in Windows or has an error.

 

Thank you very much for your future help

 

Arnoldo Alvarez

 

 

 

 

Please use plain text.
New Contributor
charoo
Posts: 4
Registered: ‎04-06-2012
My Device: Playbook

Re: Problems with Ripple and Webworks, i can not use them.

[ Edited ]

Hello Arnoldo!

 

I don't think your problem is related to your spanish Windows version. I think the problem is that you have the x64 JDK installed. Take a look at this post (message #21). syk0 states that the x86 JDK is required even if you're using a x64 OS.
I use a x64 windows and had some problems, too. So I followed that recommandations and uninstalled all those (x64) java stuff, I installed previously. After using the x86 stuff everything worked fine.

Well, it nearly worked fine. Next I faced the quite famous ripple blank screen problem ;-) which you may encounter, too. If you find yourself having this problem too, take another look at the linked post above. That problem is solved in message #27.

 

regards

charoo

Please use plain text.
New Contributor
aalvarez15
Posts: 5
Registered: ‎04-06-2012
My Device: Blackberry Playbook

Re: Problems with Ripple and Webworks, i can not use them.

Hi again. i have tried what you suggested and i can not install webworks or run ripple 0.9.0.16 yet. I really need help, here are the error messges of the problems:

 

1. when i try to run Ripple after is installed:

 

C:\Program Files\Research In Motion\Ripple 0.9.0.16\QtOpenGL4.dll is not designed for executing in Windows or has an error. Try installing the program again through the originals installation media or contact with your system administrator.

 

2. When I try to install Webworks:

 

C:\Users\Arnoldo\Documents\Blackberry Playbook\Playbook Software\WenWorks tablet\I1333745983\Windows\resource\jre\bin\client\jvm.dll is not designed for executing in Windows or has an error. Try installing the program again through the originals installation media or contact with your system administrator.

 

OS: Windows 7 64 bit

JDK SE Development kit 6 update 31

Ripple installed : 0.9.0.16

Blackberry webworks SDK 11.5.0.0

 

 

Please use plain text.