Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
BlackBerry Development Advisor
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: RIM, you cannot be serious about this

Hi Everyone,

 

I'll see if I can shed some light on what you are experiencing..

 

1) Applications must be built with WebWorks Beta 3 because between 0.9.3 and 0.9.4 the system WebKit webview API that we use to render WebWorks applications had its API method signatures changed.

 

Our WebWorks team had to re-write some of our code to work with the new system API.  The fact that the system API changed signatures meant that any application built/compiled with Beta 2 (targetted at 0.9.3) would result in a binary incompatible application on 0.9.4 or the 1.0.X version of the PlayBook OS.  It just plain old will not run!

 

This holds true for any application on the device that use the WebKit webview API... including AIR applications.  The unfortunate part is that this is the core API used for WebWorks.

 

2) There were actually very little changes in the WebWorks SDK in Beta 3.  Primary focus was to make sure that what was being compiled was compatible with 0.9.4 and RTM 1.0

 

3) The majority of issues that you are seeing in your application running on 0.9.4 simulators are from continual changes in the the WebKit rendering engine leading up to RTM 1.0.  From what I can tell from many different posts on the forum is that there are some critical regression issues, and font changes in 0.9.4.

 

4) The App World team is likely denying applications built with Beta 2 targetted for 0.9.3 because they will not run on a device and so they cannot be added to the App World storefront because they simply will not work for anyone who purchases a PlayBook.  Applications built with Beta 3 that will run on 0.9.4 can be accepted because they will run on a production PlayBook

 

End Result.....

 

At the moment this places you in-between a rock and a hard place.  0.9.3 Beta Browser works better than 0.9.4 Beta Browser but you can't use 0.9.3 to test your apps because apps that run on 0.9.3 are not binary compatible with the software that App World is telling you to use :smileysad:

 

I know that everyone is eager to have their applications accepted to App World in order to take advantage of the free PlayBook offer.  

 

I will reach out to the internal teams to get their advice.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
BlackBerry Development Advisor
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: RIM, you cannot be serious about this

From the display perspective, it looks like setting the initial scale to 1.0 helps make the layout be the same on 0.9.3 and 0.9.4

 

 

<meta name="viewport" content= "width=device-width, height=device-height, initial-scale=1.0">

 

http://supportforums.blackberry.com/t5/Web-Development/Did-the-0-9-4-simulator-change-the-device-pix...

 

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
Developer
biggerCC
Posts: 270
Registered: ‎12-13-2010
My Device: PlayBook 16GB, BB10 Dev Alpha
My Carrier: o2 (de)

Re: RIM, you cannot be serious about this

OK, we figured it out.

He is on a Windows machine with several user accounts for different purposes (don't ask me, why). While his dev account is admin, it could run bbwp without the .dll error.

So I tried bbwp from his main account: voila. Works just fine.

- - -
My approved apps @ App World
Please use plain text.
Trusted Contributor
sh2sg
Posts: 177
Registered: ‎03-10-2011
My Device: Not Specified

Re: RIM, you cannot be serious about this

The Denied email said re-compile with 0.9.4 SDK.

 

Is there a v0.9.4 SDK? There is only beta 3 SDK.

Please use plain text.
BlackBerry Development Advisor
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: RIM, you cannot be serious about this

 


sh2sg wrote:

The Denied email said re-compile with 0.9.4 SDK.

 

Is there a v0.9.4 SDK? There is only beta 3 SDK.


They meant to say that you must compile it with Beta 3 so that it is compatible with the OS 0.9.4

 

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
New Developer
kalbr88
Posts: 7
Registered: ‎03-10-2011
My Device: Not Specified

Re: RIM, you cannot be serious about this

Thanks, didn't realize there was a newer version than what I had.

Please use plain text.