Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
devan
Posts: 4
Registered: ‎08-05-2009
My Device: Not Specified

RTSP Streaming

Hi all,

 

I am having trouble getting my 8310 to play an audio stream from my Darwin streaming server. I have tested the stream in Quicktime and VLC and it plays fine, but when I go to it on my BlackBerry it seems to initialize, I get the (correct) audio time at the bottom and the timer / scroll bar behave mostly as you would expect them to when playing a clip.

 

The only problem however is there is zero audio output. 

 

I am using the following commands to make the file:

 

faac test.wav -q 347 -o test.aac
mp4creator -create=test.aac -hint=1  -optimize  test.mp4

 

and they look like this when done:

 

Track    Type    Info
1    audio    MPEG-2 AAC LC, 168.960 secs, 32 kbps, 8000 Hz
2    hint    Payload mpeg4-generic for track 1

 

Anybody see where I am going wrong?

 

Thanks,

 

Devan

Please use plain text.
New Developer
MagnaCartaHG
Posts: 12
Registered: ‎06-09-2009
My Device: Not Specified

Re: RTSP Streaming

I'm in the exact same boat. I also have a BlackBerry Storm which plays the stream back and progresses perfectly, either as pure audio or audio and video but I get no sound output. I'm also using Darwin. Have you solved this problem or have any leads that would help me troubleshoot?

 

I've tried constant bit rate, I've tried turning off parametric stereo when encoding. I'm not sure where to go next. Any ideas?

 

Kwasi

Please use plain text.
New Developer
MagnaCartaHG
Posts: 12
Registered: ‎06-09-2009
My Device: Not Specified

Re: RTSP Streaming

I'm using a BlackBerry Curve 8300, by the way.
Please use plain text.
New Developer
devan
Posts: 4
Registered: ‎08-05-2009
My Device: Not Specified

Re: RTSP Streaming

8310 / 8320 here...

 

Have not solved the problem yet, but the closest I have come is taking one of the sample mp4 files that comes with DSS (which work fine), stripping out the video and audio, and then re-muxing them into a new mp4 file. This ends up with the audio playing (albeit choppy and broken) before the video loop starts.

 

*sigh*

Please use plain text.
New Developer
MagnaCartaHG
Posts: 12
Registered: ‎06-09-2009
My Device: Not Specified

Re: RTSP Streaming

So far the only thing I've gotten to stream on Darwin to my Curve is AMR-NB, but sound quality is totally unacceptable. I've tried encoding in AAC in every which way using differing birates, AAC-LC vs. HE-AAC. I've tried mpeg4-generic hinting vs. mpeg4-latm hinting. I've used different encoders FAAC vs. NeroEncoder. I'm starting to question if this is even possible.

 

Can someone confirm streaming AAC with a URL on a Curve 8300 running OS 4.5.0.110? I'm using AT&T's network.

Please use plain text.
New Developer
devan
Posts: 4
Registered: ‎08-05-2009
My Device: Not Specified

Re: RTSP Streaming

 

I can confirm it, just try moving some of the DSS sample mp4 files into /var/dss/movies - they are mp4, AAC and hinted - and work just fine on the Curve..

Please use plain text.
New Developer
MagnaCartaHG
Posts: 12
Registered: ‎06-09-2009
My Device: Not Specified

Re: RTSP Streaming

They play on mine, but I still don't get any sound. They play on my Storm with sound, but still no sound on the 8300.
Please use plain text.