Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

New Developer
Posts: 6
Registered: ‎02-03-2010
My Device: Bold
My Carrier: AT&T

Release of widgets?

I guess I'm confused about the current availability of widgets.  They cant be run on an actual blackberry unless it has 5.0 OS, right?  And that will be available when?


If we're going through a BES, does that mean we can push these widgets now?

All Replies
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: Release of widgets?

Hi there,


Yes, BlackBerry widgets must run on the 5.0 operating system. This operating system is already available on many devices.


The only thing that is Beta about the BlackBerry widget technology is the tooling.  We're still adding a few more features before we fully RTM the tooling.


You can push widgets down to any BlackBerry Smartphone running version 5.0 operating system

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter