Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
UserBB33
Posts: 32
Registered: ‎05-05-2011
My Device: BB9700
My Carrier: mts
Accepted Solution

Resource could not be retrieved

Hi.

I'm calling webservices from BB WebWorks Application. I'm using XMLHttpRequest to call the webservice. When I print the responseText, It says Resource could not be retrieved because it is not found in config.xml. I have added the url in config.xml too. Yet I get the error.

Here is my config.xml code:

<?xml version="1.0" encoding="UTF-8"?>
<widget xmlns="http://www.w3.org/ns/widgets" xmlns:rim="http://www.blackberry.com/ns/widgets" version="1.0.0.0">
  <name>LoginWidget</name>
  <access subdomains="true" uri="http://localhost/Mobile.Gateway/Authentication.svc"/>
  <content src="Login.html"/>
</widget>

 

What am i missing?

 

Please Note:

From normal IE when i run the html files I get the response.

Thanks in advance

Please use plain text.
Contributor
UserBB33
Posts: 32
Registered: ‎05-05-2011
My Device: BB9700
My Carrier: mts

Re: Resource could not be retrieved

This is solved. Just posting the solution hoping somebody will be benefited :smileyhappy:

The probelm is that i gave the entire URL http://localhost/Mobile.Gateway/Authenticatio​n.svc in the config.xml. When i just gave only till the domain name ("http://localhost/"),  It worked fine.

Please use plain text.