Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
Posts: 7
Registered: ‎03-01-2012
My Device: Bold 8800
My Carrier: N/A

Ridiculou - Input box behaviour on click (OS7, SDK 2.3.1.5)

Hey all, after finished an app for os6, I started updating it for os7.

 

I've found that it takes two to three clicks to select an input box .

 

The first click highlights the input box and gives it a blue border. The second click enters it.

 

To move from that to another input box (or to click a button) again takes multiple clicks, one "wasted" to highlight, one to enter.

 

This behaviour is unacceptable for my app - and leaves the user clicking the screen repeatedly, like it's faulty.

 

The first click (the one that highlights) doesn't trigger click, mousedown or focus in jquery, so I can't even bodge it.

 

I'm running SDK  - 2.3.1.5.

 

 

Please, someone, help me!

(The biggest kicker is os6 handles it correctly, and so does the BB web browser!)

New Contributor
Posts: 7
Registered: ‎03-01-2012
My Device: Bold 8800
My Carrier: N/A

Re: Ridiculou - Input box behaviour on click (OS7, SDK 2.3.1.5)

[ Edited ]

Bump - someone HAS to know the answer to this - surely?
I recorded a video to demonstrate it:

 

http://www.youtube.com/watch?v=ejG2pXIB8ds

Highlighted
New Contributor
Posts: 7
Registered: ‎03-01-2012
My Device: Bold 8800
My Carrier: N/A

Re: Ridiculou - Input box behaviour on click (OS7, SDK 2.3.1.5)

Well I've found the bug and fixed it.

 

I would post the code here, but I'm not going to.

 

Why?

 

So far, I've asked 2 questions. 2 simple questions on this so called support forum.

 

My posts have had 1443 views.

 

I've received ZERO answers.

 

I've had to figure the answers out myself - due to poor documentation and zero support. Wasting hour after hour.

 

So no, Blackberry, I'm not going to do your job for you and find bugs, fix bugs, and post answers - when you don't even acknowledge posts in your "support" forum.

 

(PS - anyone who is stuck on this problem, feel free to message me).