Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Trusted Contributor
usr501
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900
My Carrier: rogers

Ripple Emulator throwing errors

[ Edited ]

along with config file reporting errors, an error loading page error pop up ( jquerymobile) and uuid numbers appearing between page transitions I got this error today. see below:screenshot of ripple emulator for BB10

Please use plain text.
Administrator
astanley
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Ripple Emulator throwing errors

This is a number of different questions.

 

>>along with config file reporting errors,

What errors is it reporting?  Be specific and we can narrow down what the problems may be.

 

>> an error loading page error pop up ( jquerymobile) and

Can you provide more details, and perhaps a screenshot?

 

>> uuid numbers appearing between page transitions

Does your application display these uuid numbers in any part of its content?

 

>> I got this error today. see below:

If you start the ripple services from the build panel, and then click on the "About Ripple emulator" button in the settings panel, you should see the version info updated correctly.

 


Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
Please use plain text.
Trusted Contributor
usr501
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900
My Carrier: rogers

Re: Ripple Emulator throwing errors

The error loading page is JqueryMobile. However this app is running on playbook QNX and is live in appworld.

I'm reluctant to change code at this point since it is working on playbook plus BBOS 6 and 7.

I'm working with Ant/JqueryMobile/Phonegap environment plus the relevant BB SDK  for the latter operating systems and it builds fine.

This is my first attempt to work solely with webworks and Ripple for BB10. I have no success." FYI-I have stripped out phonegap code "

 

here is the jquerymobile error screenshot. The BB10 app would not work locally so I put it on server. As such the error is present.

the UUid numbers are not part of anything in my code.The XML file is very sensitive in BB10- config file disappears easily.

JqueryMobile using Json# for navigation. The Index.html page is multipage and it's links work there are 2 external links and they work as well. it's the two internal links that won't load in emulator that show "error loading page"

ripple emulator screenshot

 

Please use plain text.
Trusted Contributor
usr501
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900
My Carrier: rogers

Re: Ripple Emulator throwing errors

UUid numbers showing on page transitions and at bottom of page.I can't capture screen as it transitions but have included shot of bottom of page showing UUid numbers in bottom left corner of screen on simulator 9.7ripple UUid numbers showing

Please use plain text.