Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
aligs
Posts: 17
Registered: ‎11-19-2010
My Device: Nexus One
My Carrier: Vodafone

Ripple loading all javascripts twice!

[ Edited ]

Just wanted to share my joy with you that I just wasted a few hours fixing a bug not knowing that Ripple runs all the javascript in your page TWICE!


Test it for yourself:

 

<!DOCTYPE html>
<html>
	<head>
	</head>
	
	<body>
		<script type="text/javascript">
			var i = 0;
			console.log("Run #"+i);
		</script>
		Empty.
	</body>
</html>

 

This is the output in Ripple's web inspector:

 

 

bug.html:9    Run #0
ripple.js:351 WebWorks :: -----------------------------------------------------------
ripple.js:351 WebWorks :: Pay no attention to that man behind the curtain.
ripple.js:351 WebWorks :: Environment Warning up again (Set main batteries to auto-fire cycle)
ripple.js:351 WebWorks :: Initialization Finished (Make it so.)
bug.html:9    Run #0

 

 

I just can't believe it. Please tell me it's only happening on my machine!

 

Please use plain text.
Developer
rorybarnes
Posts: 214
Registered: ‎01-07-2011
My Device: Bold 9900
My Carrier: Rogers

Re: Ripple loading all javascripts twice!

Nope it is a known issue, happens to everyone.

 

I have started putting a check to see if the blackberry object exists, if it idoesn't my code doesn't run.

--
Rory (@roryboy)
Click "Accept as Solution" if post solved your original issue. Give like/thumbs up if you feel post is helpful
Please use plain text.