Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
moridin1138
Posts: 14
Registered: ‎10-11-2012
My Device: 9900

Re: Ripple - "Error: Permission denied: connect" when attempting to build

No proxy needed.  Java is the only thing I can think of that's changed.  I've also tried via two separate networks and internet connections.

 

Is there any way I can test connectivity to the signing servers?

BlackBerry Development Advisor
twindsor
Posts: 832
Registered: ‎07-15-2008
My Device: Passport
My Carrier: Bell

Re: Ripple - "Error: Permission denied: connect" when attempting to build

Can you see if you can reach this page?

http://www.rim.net/Websigner/servlet/BAR-Waterloo/

 

If you try in a browser and get a blank page then you are able to reach it.

Tim Windsor
Open Source Technical Lead
Contributor
moridin1138
Posts: 14
Registered: ‎10-11-2012
My Device: 9900

Re: Ripple - "Error: Permission denied: connect" when attempting to build

[ Edited ]

Ill try and report back.

Contributor
moridin1138
Posts: 14
Registered: ‎10-11-2012
My Device: 9900

Re: Ripple - "Error: Permission denied: connect" when attempting to build

Comes up as "The page you have requested has been moved or no longer exists."

If connectivity is not the problem.... :smileyfrustrated:
Contributor
moridin1138
Posts: 14
Registered: ‎10-11-2012
My Device: 9900

Re: Ripple - "Error: Permission denied: connect" when attempting to build

Strange, after a couple of reboots (the first didnt do anything), it seems to be working again.  I don't get it!

BlackBerry Development Advisor
twindsor
Posts: 832
Registered: ‎07-15-2008
My Device: Passport
My Carrier: Bell

Re: Ripple - "Error: Permission denied: connect" when attempting to build

Glad to hear it and sorry that I couldn't help more with whatever the problem was.

 

I was actually given the wrong link too. You won't need it now, but for anyone else who comes across this thread with a similar problem, the URL to test for connectivitiy is actually:

 

www.rim.net/Websigner/servlet/RDK-Waterloo

Tim Windsor
Open Source Technical Lead
Contributor
moridin1138
Posts: 14
Registered: ‎10-11-2012
My Device: 9900

Re: Ripple - "Error: Permission denied: connect" when attempting to build

Thanks Tim.

Since there wasnt much the Goog returned for this error, hopefully all this info will help anyone else that suffers the same fate in the future.  :smileyvery-happy:

Contributor
moridin1138
Posts: 14
Registered: ‎10-11-2012
My Device: 9900

Re: Ripple - "Error: Permission denied: connect" when attempting to build

For the record, this happened again, but again, a reboot fixed the issue.

 

It may have something to do with me connecting and disconnecting from my company's VPN, but I cannot confirm this (as signing seems to work when connected and disconnected, but eventually stops working altogether).