Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
Posts: 3
Registered: ‎02-06-2013
My Device: N/A - Developer
My Carrier: N/A
Accepted Solution

Ripple says: there was a problem loading webworks.js

I'm trying to get started with BB10 WebWorks. I downloaded Phonegap 2.3, set up the sample project, hosted it locally using MAMP, and opened it in Chrome with Ripple.

 

Ripple alerts "there was a problem loading webworks.js", and the chrome console shows that GET local:///chrome/webworks.js failed.

 

Other possibly-related things:

 - Cordova logs "Unknown user agent?!?!? defaulting to java" to the console.

 - "Viewport target-densitydpi is not supported." was logged to the console. I removed the target-densitydpi parameter from the viewport meta-tag and it stopped complaining.

 

I'm using Ripple v0.9.13 in Chrome 24.0.1312.57 on Mac OS X 10.8.2 (Mountain Lion).

Developer
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: Ripple says: there was a problem loading webworks.js

Hey Jtward,

 

Have you downloaded and installed the latest BlackBerry WebWorks SDK on to your computer?

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
New Contributor
Posts: 3
Registered: ‎02-06-2013
My Device: N/A - Developer
My Carrier: N/A

Re: Ripple says: there was a problem loading webworks.js

I have; do I need to do anything to hook it up?

Developer
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: Ripple says: there was a problem loading webworks.js

Hey,

 

I think it has something to do with the platform that you chose. I'm assuming that you chose the Phonegap option for the platform and because of that Ripple doesn't import the webworks library it needs. I think you are going to pick one or the other. Using phonegap and compiling with webworks will work -- u just need to take out the local:///webworks.js line and it should work. Not sure what the reprecussions are -- have never used Phonegap.

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
New Contributor
Posts: 3
Registered: ‎02-06-2013
My Device: N/A - Developer
My Carrier: N/A

Re: Ripple says: there was a problem loading webworks.js

Ah, I see; so phonegap assumes that you're building the app for the device/simulator rather than ripple. Kinda makes sense although it's not very clear in the phonegap docs. I'll have a play tomorrow when I'm back at my mac.

Thanks for your help