Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
ruebyi
Posts: 17
Registered: ‎02-14-2011
My Device: 9700

Ripple won't pack my App...

Hey Guys!

 

I'm creating my first PB launcher and I'm running into a problem...

Ripple won't pack my app...

 

It gives me only an Error:

"Oh Snap! Build request failed with message: parsererror"

 

Can anyone help me?

 

ruebyi

Contributor
TheWakeUpCall
Posts: 48
Registered: ‎03-30-2011
My Device: Playbook

Re: Ripple won't pack my App...

Check your config file is valid XML would be my guess?
New Developer
tomkranz
Posts: 9
Registered: ‎02-13-2012
My Device: Playbook

Re: Ripple won't pack my App...

I had this issue as well - double check your config.xml. I'd made a typo in one of the parameters and Ripple was (quite rightly) choking on it.

 

If you've got a context-sensitive editor it should automatically highlight mismatched tags for you.

 

Cheers,

TOM

Developer
shnuffy
Posts: 268
Registered: ‎08-19-2009
My Device: Bold 9700

Re: Ripple won't pack my App...

Just as an aside: I wish Ripple would provide more information about any of the errors it runs into. They're always painfully vague "Oh snap! Crazy error! That's all." and no way of determining where the error is, what line caused it, even what file it's talking about. Very time consuming them to go comb through everything to try to find some obscure (often simple syntax) error. 

New Developer
tomkranz
Posts: 9
Registered: ‎02-13-2012
My Device: Playbook

Re: Ripple won't pack my App...

^^ totally this. It's just calling the SDK behind the scenes - putting the output of the SDK build/sign process underneath the error message would be hugely helpful - at least then you'd know where to look.

Or log it all to a file so we know where to go to find out more information. Either of these would make Ripple hugely more helpful, especially when it comes to hard-to-spot but irritating errors like typos or slightly wrong syntax somewhere.

Cheers,
TOM
Visitor
guo_junmin
Posts: 1
Registered: ‎02-25-2012
My Device: Playbook

Re: Ripple won't pack my App...

Hello ruebyi,

 

Today, I met exactly the same problem as yours. Actually I did nothing but copied code from "Getting started". Moreover, while I tried to visit " http://www.blackberry.com/n/widgets/", my browser showed "404-Page not found". I'm not sure if it's normal.

 

Would you please share some tips?

 

Thank you

 

Junmin

Developer
SumiGhosh
Posts: 435
Registered: ‎09-20-2011
My Device: Z10 LE, Playbook, DevAlpha C, 9900, 9380

Re: Ripple won't pack my App...

Check you archieve had .project file. If it is there please remove and package your app.
Retired
astanley
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Ripple won't pack my App...

I agree these errors should be more descriptive to help troubleshoot what the underlying problem is.  I have raised this in the past as a point of concern, and have also filed a feature in Github: https://github.com/blackberry/Ripple-Framework/issues/96

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
Contributor
djreyes
Posts: 35
Registered: ‎11-13-2010
My Device: Torch 9810

Re: Ripple won't pack my App...

I am having a similar problem but the error I get is

 

"Oh Snap! Build request failed with message: /bin/sh: /Developer/SDKs/Research In Motion/BlackBerry WebWorks SDK 2.3.1.5/bbwp/bbwp: Not a directory"

 

I'm not really sure what to do here. New developer seeking help

DJ Reyes
Retired
astanley
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Ripple won't pack my App...

>> "Oh Snap! Build request failed with message: /bin/sh: /Developer/SDKs/Research In Motion/BlackBerry WebWorks SDK 2.3.1.5/bbwp/bbwp: Not a directory"

 

 

That sounds to me like the SDK path you have entered in the Settings screen is incorrect?

 

Try entering this path instead (no /bbwp at the end)?

 

/Developer/SDKs/Research In Motion/BlackBerry WebWorks SDK 2.3.1.5

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.