Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
djreyes
Posts: 35
Registered: ‎11-13-2010
My Device: Torch 9810

Re: Ripple won't pack my App...

I don't put /bbwp at the end of the path, it just seems like Ripple is looking for that directory within the webworks directory.

 

What I put in the settings for Ripple is exactly the path you stated above.

DJ Reyes
Contributor
djreyes
Posts: 35
Registered: ‎11-13-2010
My Device: Torch 9810

Re: Ripple won't pack my App...

Ok, at someone's elses suggestion on Twitter, I created a directory called bbwp and put on the contents of the WebWorks SDK folder into that one, since that was what Ripple was looking for. However, this has now thrown another error up, one which I have no clue whatsoever in figuring out what it means.

 

"Oh Snap! Build request failed with message: [ERROR] Invalid command line parameters bbwp version 2.3.1.5 Copyright(C) 2010-2011 Research In Motion http://www.blackberry.com/developers/webworkssdk/ bbwp [drive:][path]archive [-s [dir]] [-g [password]] [-o dir] archive Specifies the .zip file to compile -s Save source. The default behaviour is to not save the source files. If dir is specified then creates dir\src\ directory structure. If no dir specified then the path of archive is assumed -g Sign the .cod file after compilation using password. If both -g and password are not present then the .cod will not be signed. If -g is present and password is not, Signature Tool will prompt for entering password -o Redirects output file location to dir (.cod, .alx, .jad). If both -o and dir are not specified then the path of archive is assumed -v Turn on verbose messages -d Enables Web Inspector on 7.0+ OS -h Display this usage information"

 

What now? :smileyfrustrated:

DJ Reyes
Retired
astanley
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Ripple won't pack my App...

Okay, I think I know what the problem is.  Looking at this thread again, I see that you are trying to package a PlayBook application, however you have specified the path to the Smartphone SDK.

 

 

  1. Make sure that WebWorks-TabletOS is selected from the Platforms tab
  2. Open the Settings screen
  3. In the SDK path, enter the path to the WebWorks for Tablet OS SDK, by default this is:

C:\Program Files\Research In Motion\BlackBerry WebWorks SDK for TabletOS 2.2.0.5

 

Hope that helps.

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
Contributor
djreyes
Posts: 35
Registered: ‎11-13-2010
My Device: Torch 9810

Re: Ripple won't pack my App...

Thanks, I think it seemed to have clicked with me. I'm currently installing the correct SDK now.

 

Such a rookie mistake lol.

 

Thanks for all the help.

DJ Reyes
New Contributor
ferescalona13
Posts: 2
Registered: ‎08-23-2011
My Device: 8310

Re: Ripple won't pack my App...

I'm having the same issue, and i have the settings correctly configured.

 

My SDK Path is C:\Program Files (x86)\Research In Motion\BlackBerry WebWorks SDK for TabletOS 2.2.0.5 

 

Even so when i package the project i can see both files (.bar and .zip) generated in my output folder, is that normal??