Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
Nitish_Pheonix
Posts: 29
Registered: ‎09-17-2012
My Device: 9810, 9800, 9700, 9900, 9300

Smartphone Application crashed every time

Hi all, 
I am checking My Application in 9800.
When I installed it, it works fine for the 1st time. When I close the app and reopen it, it didn't move to home screen.
Only the splashScreen is showing after that it closes automatically.
In my simulator it is working fine with out any problem but when I test in device the above problem is occurring.

Please help me, I got stock in the above problem and I have to solve ASAP....

Thanks & Regards,
Himansu

Thanks & Regards,
Nitish_Pheonix

Hit like if the above post is helpful to you.
Please Accept this as Solution if the above post is a solution for you.
Developer
The_Anomaly
Posts: 322
Registered: ‎08-06-2012
My Device: Dev Alpha / Playbook / Curve 9300

Re: Smartphone Application crashed every time

What does your app do the second time you open it?

 

ie:  first time creates a database maybe where the user enters a profile or settings... then second time opening uses that info <- just a scenario I thought of.

 

Does your app do anything like that?

What JS framework are you using if any?

If it helped you, click like. :smileyhappy:
Developer
Nitish_Pheonix
Posts: 29
Registered: ‎09-17-2012
My Device: 9810, 9800, 9700, 9900, 9300

Re: Smartphone Application crashed every time

Hi The_Anomaly,
once I install my app in the device, for the first time it's work properly but when I close the app and reopen it. It shows only the splash screen and closed automatically. I didn't find the reason for which it is happening. It's working fine in Simulator for every time.

I am not using any database and I am using jQueryMobile framework.

Thanks & Regards,
Nitish_Pheonix

Hit like if the above post is helpful to you.
Please Accept this as Solution if the above post is a solution for you.
BlackBerry Development Advisor
kwallis
Posts: 137
Registered: ‎01-19-2010
My Device: BlackBerry Z10

Re: Smartphone Application crashed every time

hello.  Can you please try enabling debug mode for the application and see what web inspector might be saying?  When you package your app with bbwp, please specify the -d option on the command line.  When the application runs it should show a dialog with the web inspector information that you can connect to.

 

Thanks.

Ken Wallis - Senior Product Manager, WebWorks and Android Runtime
@ken_wallis
Trusted Contributor
usr501
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900

Re: Smartphone Application crashed every time

[ Edited ]

what keypad button do you press ?or how are you closing the app?

are you programatically closing it?  id="btnExitApp" onclick="exitApp()"

Jqm on OS 6 and OS 7 will tend to hang in limbo even though you think its closed.

it works best closing app with js code that can be found in the Blackberry webworks examples/KitchenSink

 

9800.png

 

 

New Contributor
Anansy
Posts: 9
Registered: ‎02-15-2010
My Device: Torch | Playbook

Re: Smartphone Application crashed every time

I have a similar problem and i'm very desparate right now to get this working. My index.html file is on a remote server and the app quits unexpectedly whenever the index page finishes loading. i white listed the domain and it doesnt seem to help.

Trusted Contributor
usr501
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900

Re: Smartphone Application crashed every time

Anansy,

 

 post html and xml code  using the insert code button above :smileyvery-happy:

 

New Contributor
Anansy
Posts: 9
Registered: ‎02-15-2010
My Device: Torch | Playbook

Re: Smartphone Application crashed every time

[ Edited ]

<?xml version="1.0" encoding="utf-8"?>

<widget xmlns="http://www.w3.org/ns/widgets" xmlns:rim="http://www.blackberry.com/ns/widgets" version="2.0" rim:header="RIM-Widget: rim/widget" id="ME">  

 

<author href="http://www.me.com/" rim:copyright="Copyright 2012 ME">ME</author>  

 

<rim:navigation mode="focus" />  

 

<name>Webworks App</name>     <description> Some app... </description>  

 

<rim:smileysurprised:rientation mode="portrait"/>  

 

<rim:loadingScreen  foregroundImage="images/banner.png"  onLocalPageLoad="true">   

<rim:transitionEffect type="zoomIn" /> 

</rim:loadingScreen>

     

<icon src="icons/icons-1.png"/>    

<icon src="icons/icons-1.png" rim:hover="true"/>

     

<content src="http://www.mydomain.com/index.html" >  </content> 

 

<access uri=http://www.mydomain.com subdomains="true">        

 

< feature id="blackberry.system.event"  required="true" version="1.0.0.0"/>   

<feature id="blackberry.app"  required="true" version="1.0.0.0"/>   

<feature id="blackberry.app.event"  required="true" version="1.0.0.0"/>  

<feature id="blackberry.ui.dialog"  required="true" version="1.0.0.0"/>  

<feature id="blackberry.utils"  required="true" version="1.0.0.0"/>

<feature id="blackberry.invoke"  required="true" version="1.0.0.0"/>   

<feature id="blackberry.invoke.BrowserArguments"  required="true" version="1.0.0.0"/>  

<feature id="blackberry.identity"  required="true" version="1.0.0.0"/>  

 <feature id="blackberry.io.dir"  required="true" version="1.0.0.0"/>       

 

</access>          

 

<rim:cache disableAllCache="true" />    

<rim:connection>   

<id>BIS-B</id>

<id>TCP_WIFI</id>

<id>MDS</id>

<id>TCP_CELLULAR</id> 

<id>WAP2</id>

<id>WAP</id> 

</rim:connection>      

 

</widget>

 

 

As soon as my index.html located on mydomain.com  onload event fires, the app quits.

 

 

 

Trusted Contributor
usr501
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900

Re: Smartphone Application crashed every time

[ Edited ]

did you lose the quotation marks around "http://mydomain.com"  when you pasted?

and content screen normally is  <content src="index.html" /> remove the trailing </content>

like this for uri  <access uri="http://www.mydomain.com" subdomains="true" />

remove the  trailing </access>

 remove the dead  href="http://www.me.com/" from the author tag - dead links cause problems 

I suggest you setup in ripple 9.10/chrome  and then load your remote index.html and debug using the javascript console built into chrome

New Contributor
Anansy
Posts: 9
Registered: ‎02-15-2010
My Device: Torch | Playbook

Re: Smartphone Application crashed every time

Yes quotes were lost during the post, i removed the trailing slashes and made the correction to the author link as suggested. the app still quits after the index has loaded.