Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
radoon
Posts: 9
Registered: ‎05-13-2013
My Device: Z10
Accepted Solution

Splash Screen not detecting landscape orientation on Z10

I am working on a webworks application on BB10 and am trying to set both a portrait and landscape splash screen. I followed the API document in using the screen resolutions, but it is not pulling the landscape splash screen (just uses the portrait one). I am testing this directly on the Z10 using a debug token.

 

My config file has the following:

<rim:splash src="images/splash-720x720.png" />
<rim:splash src="images/splash-1280x768.png" />
<rim:splash src="images/splash-768x1280.png" />

Contributor
DigitalMaestro
Posts: 38
Registered: ‎03-07-2012
My Device: Dev Alpha B, Playbook 16GB, Z10 LE

Re: Splash Screen not detecting landscape orientation on Z10

I've had a similar issue in the past.  What I found was that when the app was compiled with the web inspector enabled and not signed, the incorrect splash screen would be displayed on app startup.  However if the app was signed and the web inspector disabled everything worked as expected.

 

Perhaps your issue is similar.  If you haven't tried yet then sign your app without web inspector and deploy to your device and see if the splash screen works properly then.

 

Cheers

DM

 

 

------------
"The shortest answer is doing." - Jacula Prudentum
My app: Cashalyst
New Developer
radoon
Posts: 9
Registered: ‎05-13-2013
My Device: Z10

Re: Splash Screen not detecting landscape orientation on Z10

Thanks, DM. I'll keep an eye on this when I'm ready to sign my app. Still in heavier dev so I'm not ready to part from my precious debug token yet.
New Developer
radoon
Posts: 9
Registered: ‎05-13-2013
My Device: Z10

Re: Splash Screen not detecting landscape orientation on Z10

It looks like the 10.1 update fixed this issue for me. The app now pulls the correct splash screen based on screen orientation.