Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
faizandedia
Posts: 19
Registered: ‎02-14-2013
My Device: 9360

UI Footer, bottom:0 not working on device

I am creating UI which has full screen UI (not scrollable). I added footer to the bottom of the Page using div element which is working fine in ripple emulator but on device its seems I can't add footer. the css is here for the footer:

 

.div_bottomBar {

    

   width:100%;

   height: 50px;

   position: absolute;

   bottom:0;   

   background-color: red;

   

}

 

it is appearing above to the screen on device but on emulator it is fine.

 

any help?

 

Thanks

 

 

Developer
nathanpc
Posts: 134
Registered: ‎05-19-2012
My Device: Torch 9800, PlayBook 64GB, Dev Alpha

Re: UI Footer, bottom:0 not working on device

Strange, I have a footer in my app and it works perfectly. This is the code that I'm using:

footer {
    position: absolute;
    left: 0;
    bottom: 0;
    width: 100%;
    height: 50px;
    -webkit-box-sizing: border-box;
}

Anyway, try debugging using the Remote Debugger. It's extremely helpful to test CSS.

If I helped you please click the "Like" button to support my work.
My apps: CherryNotes - Bookmarked - Requests
Social Me: about.me - Twitter
Contributor
faizandedia
Posts: 19
Registered: ‎02-14-2013
My Device: 9360

Re: UI Footer, bottom:0 not working on device

Don't know why this happening only on device.. well any other way to make footer(align div to bottom always)  ?

 

Thanks..