Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
jamesgibbons
Posts: 26
Registered: ‎06-01-2010
My Device: Dev Alpha, PlayBook
Accepted Solution

Unable to use WebGL frame buffer with PlayBook

I've gone through the lessons on http://learningwebgl.com/lessons/, but cannot get the lesson 16 demo to display on my PlayBook (OS 2.1.0.840). I am left with an empty white canvas. The demo works fine in Chrome. According to the Blackberry WebGL Documentation I think the WebGL functions used in the demo are all supported. According to web inspector, there are no errors on the page.  Does anyone know why the canvas isn't displaying? My guess is that the problem revolves around a frame buffer issue as I haven't been able to get any frame buffer code to render on the PlayBook. Has anyone used frame buffers successfully on a PlayBook?

 

Thanks!

___________________________________________________________
My latest Blackberry 10 app Audiobooks! :smileyhappy:

My latest PlayBook app Photojam!

Find me on Twitter: GoGibbons
Please use plain text.
Developer
Developer
LBP
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: Unable to use WebGL frame buffer with PlayBook

Hi.

 

Are you running the lessons in the browser or packaged them within an app? I tried here with PlayBook running OS 2.0.1.358 and it seems working well in the browser like shown in the screenshot below. The first was the notification that the page uses WebGL so I needed to grant permission and then it was working really good on the device!

 

IMG_00000078.jpg


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
Please use plain text.
Developer
jamesgibbons
Posts: 26
Registered: ‎06-01-2010
My Device: Dev Alpha, PlayBook

Re: Unable to use WebGL frame buffer with PlayBook

Thanks so much LBP!! I downgraded my PlayBook to 2.0.1.668 and the page, as well as my app, rendered correctly! I filed a bug report in JIRA as I think this issue is limited to 2.1.*. Please kindly vote for the issue so that it is fixed before 2.1 is public.

___________________________________________________________
My latest Blackberry 10 app Audiobooks! :smileyhappy:

My latest PlayBook app Photojam!

Find me on Twitter: GoGibbons
Please use plain text.
Developer
Developer
LBP
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: Unable to use WebGL frame buffer with PlayBook

Hi. Good to know you filed a bug report but it seems the JIRA isn't quite well configured since other devs doesn't have permission to view it because of the group permissions. I got this message:

 

You cannot view this issue because you are not the issue reporter or assignee, a member of the project group, or a member of the issue group and this issue is closed or in triage.

I filed a bug for BB10 and it is the same, only I'm able to view it and the people at RIM. I pointed to this in a discussion with a Community Manager since it isn't quite well for others to not be able to view and comment on those issues and bugs.

 


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
Please use plain text.
BlackBerry Development Advisor
oros
Posts: 1,557
Registered: ‎04-12-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: Unable to use WebGL frame buffer with PlayBook

[ Edited ]

Hi guys, I've confirmed this issue on my device. I'll log into the JIRA cases today and escalate them to dev. LBP, could you please link your issue here? I should still be able to see it when logging in and will flip them both to visible by the community.

 

EDIT: Once I sort out these login issues.


Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
Please use plain text.
Developer
Developer
LBP
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: Unable to use WebGL frame buffer with PlayBook

Hi Erik,

 

the reported issue BBTEN-121 was closed to reopen it as BBTEN-124 and it seems others can not comment to it. When I got the email about reopening I wasn't able to access the BBTEN-124 because of permission.


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
Please use plain text.
BlackBerry Development Advisor
oros
Posts: 1,557
Registered: ‎04-12-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: Unable to use WebGL frame buffer with PlayBook

Hi guys,

 

I've escalated the WebGL issue and also made it public so that it should be visible. Can you please confirm?

 

WebGL Frame Buffer doesn't workin 2.1.0.840:

https://www.blackberry.com/jira/browse/TABLET-671

 

 

BBTEN-124 appears to be open to the public. It's available at the following URL, but I'll try to configure some settings to check whether something is missing.

 

On off button is not operating as it should be since updated to BlackBerry10 Dev Alpha OS 10.0.06

https://www.blackberry.com/jira/browse/BBTEN-124

 

 

Just to confirm, BBTEN-124 can not be currently accessed, correct?


Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
Please use plain text.
Developer
Developer
LBP
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: Unable to use WebGL frame buffer with PlayBook

Right now it seems RIM has worked on the JIRA permissions since I could access both of them. Days ago I couldn't. But the login is buggy I think when I want to login to JIRA directly through the issue URLs it isn't possible, I need to use the dashboard and then it asks me if I want to use BB-ID or BB-JAM login and it is working well.


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
Please use plain text.
BlackBerry Development Advisor
oros
Posts: 1,557
Registered: ‎04-12-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: Unable to use WebGL frame buffer with PlayBook

Thanks LBP, I did switch some permissions around so it may have been from that. I'll pass the login issues to our web team.


Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
Please use plain text.