Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
rg_bb
Posts: 21
Registered: ‎04-25-2012
My Device: 9800
Accepted Solution

Upgrading Eclipse WebWorks SDK Plugin to 2.3.1.5

Hi,

 

I have read this (http://supportforums.blackberry.com/t5/Web-and-WebWorks-Development/Eclipse-Plug-in-for-Webworks-SDK...) and I am well aware the Blackberry would like developers to move on to Ripple for development. However, I am working with the Push API (BIS) which is not fully supported on Ripple, so I need to use a Device/Simulator.

 

I have found that using the WebWorks packager (SDK 2.0.0.*) that comes with the Eclipse Plugin does not support all the functions I need to use in the Push API (I get Java exception errors). Instead I have been zipping the project and packaging/signing from the command-line with the latest version of the WebWorks SDK (2.3.1.5) - this works fine. My question is: How can I integrate the newer version of the WebWorks SDK into the eclipse plugin? - what should I copy over from

C:\Program Files\Research In Motion\BlackBerry WebWorks SDK 2.3.1.5

to

C:\eclipsebb\plugins\net.rim.browser.tools.wcpc_2.0.0.201103231828-18

?

Has anyone done this before? It would make packaging the app quicker and easier to deploy to simulators.

Developer
rorybarnes
Posts: 214
Registered: ‎01-07-2011
My Device: Bold 9900

Re: Upgrading Eclipse WebWorks SDK Plugin to 2.3.1.5

You could use the packager built into Ripple, even if you aren't testing in Ripple. It will deploy to the simulator for you and it always supports the latest SDK.

 https://developer.blackberry.com/html5/documentation/packaging_your_app_in_ripple_1904611_11.html

 

As for updating the SDk in the eclipse plug-in, I am not sure if copying over would work. You could back-up the original files and try :smileyhappy:

--
Rory (@roryboy)
Click "Accept as Solution" if post solved your original issue. Give like/thumbs up if you feel post is helpful
Contributor
rg_bb
Posts: 21
Registered: ‎04-25-2012
My Device: 9800

Re: Upgrading Eclipse WebWorks SDK Plugin to 2.3.1.5

Excellent, thanks. Goodbye command line!