Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Ezi
Contributor
Ezi
Posts: 21
Registered: ‎05-16-2010
My Device: Tour 9630
My Carrier: Sprint

Visual studio plug-in: JDK must be installed, but it is...

I try to install the new Visual studio plug-in, right in the beginning I get a message that the jdk 1.6 or higher must be installed.

I had it installed I reinstalled the latest version this didn’t help.

I’m running windows 7 64bit.

 

Any help?

Please use plain text.
BlackBerry Development Advisor
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: Visual studio plug-in: JDK must be installed, but it is...

I couldn't make out from your post if you installed and re-installed the plug-in or the JDK.  Do you have the Sun JDK 1.6 installed?  

 

http://java.sun.com/javase/downloads/index.jsp

 

We support the 32bit version of the JDK.  The 64bit version has had a bunch of issues on Windows 64bit operating systems so we stick with the 32bit version.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
Ezi
Contributor
Ezi
Posts: 21
Registered: ‎05-16-2010
My Device: Tour 9630
My Carrier: Sprint

Re: Visual studio plug-in: JDK must be installed, but it is...

I installed twice the jdk 64bit since I have a 64 machine... Now I try to download the regular version hopfully it'll work...

 

Thanks

Please use plain text.
BlackBerry Development Advisor
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: Visual studio plug-in: JDK must be installed, but it is...

Yeah, we have seen very odd behavior of the 64 bit JDK on Win7 64 even outside of the BlackBerry plug-ins so we make sure that all our developers are using the 32bit versions.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.