Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
mauzzamali
Posts: 16
Registered: ‎03-25-2012
My Device: Blackbery Playbook
Accepted Solution

Want to open app in BB 10 Alpha Dev simulator in debug mode

Hello,

 

I developing black berry 10 webworks app. I am using the latest sdk provided and the blackberry 10 alpha dev simulator to  run the app. Also I am using the ripple emulator of chrome to test and debug the app. 

 

I want to debug the app on simulator using browser webkit or something like that, but for some reason I am not able to do so.

 

While packaging the app I have inserted the -d option. It says on bb website that

"With your application running in the simulator, in a desktop browser, type http://<IP address of simulator>:<port number>."

 

I tried doing so but couldnt see the application in debug mode. 

 

I tried vairous port numbers, since I am using apache server

 

8080,8181,85,.....

 

Could any body help me out with this

 

Thank you very much in advance

 

 

Cheers

 

Developer
Developer
LBP
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: Want to open app in BB 10 Alpha Dev simulator in debug mode

Since you added the -d option it should work really well. All you need to do is to set the device/simulator in developer mode (Settings->Security->Developer Mode) and I asume you have already done this. In almost every case I worked with BB PlayBook and BB10 all you need to do now is point your Chrome browser to this URL+port:

 

http://<IP address of simulator>:1337

The IP shouldn't be the problem since you already deployed the app to the simulator I guess?!! So give it a try with the port number and it should work now.


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
Contributor
mauzzamali
Posts: 16
Registered: ‎03-25-2012
My Device: Blackbery Playbook

Re: Want to open app in BB 10 Alpha Dev simulator in debug mode

Thanks LBP

This port no. is the thing which I was searching for. If BB would have provided this with example, then it would have been easier.

Regards.....
Contributor
mauzzamali
Posts: 16
Registered: ‎03-25-2012
My Device: Blackbery Playbook

Re: Want to open app in BB 10 Alpha Dev simulator in debug mode