Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
alexscript
Posts: 8
Registered: ‎09-22-2009
My Device: Not Specified

Web Format/Layout Issue on 9000 and 9530

Hi Guys,

 

I'm not too sure how to precisely describe my issue.

 

On most blackberry simulators, my web page renders perfectly (or at least as expected), however, when testing on a 9000 simulators (I've tested 4.6.0.212 and 4.6.0.216) and on the 9530 simulators (I've tested the 4.7.0.41 and the 4.7.0.76) my page renders wrong, causing an effect I could only describe as squished.

 

My web pages inherit

 

"<!DOCTYPE HTML PUBLIC "-//WAPFORUM//DTD XHTML Mobile 1.1//EN" "http://www.openmobilealliance.org/tech/DTD/xhtml-mobile11.dtd">"

and I've added "<meta name="ViewPort" content="width=320; user-scalable=false; initial-scale=0.6666; maximum-scale=1.0; minimum-scale=0.6666;" />"

for iphone support.

 

I've created my page layout using tables with percentages for widths and the CSS property table-layout:fixed which seems to have been widely supported across blackberry 4.5 and up, as well as iphones, palms and windows mobile phones.

 

At first I thought it was a one off situation, but it happens to be on all 9000s and 9530s simulators I've tested.

There is no documentation linking these two models with browser issues. Other sites render fine, so it must be something I'm missing in my html.

 

Does anyone have any insight? Possibly even just on designing a page that can be rendered properly on blackberrys 4.5 and up, no exceptions? Or maybe some ideas on troubleshooting this so I can narrow down the cause of this not rendering right.

 

My only issue is with the 9000 and the 9530. I don't understand how it could only be those two.

 

Thanks in advance for any leads,

Alex

Please use plain text.
New Developer
toddm
Posts: 13
Registered: ‎01-03-2009
My Device: Not Specified

Re: Web Format/Layout Issue on 9000 and 9530

This is just a guess, but with my 9530 I had problems when using tables.  Try just using CSS if possible.

Please use plain text.
New Developer
rachna30
Posts: 6
Registered: ‎01-15-2010
My Device: Storm
My Carrier: 900MHz GSM/GPRS networks

Re: Web Format/Layout Issue on 9000 and 9530

hi,

 

even i am also having the same issue. when i test my page on 9000 simulator i get some white space at few places on my page whereas the page renders absolutely fine on other simulators. i am using only divs and presentation is done only with css, no tables are used even then the white space is coming. also the images are getting stretched in 9000 whereas in no other simulators. any point of direction would be appreciated.

 

Thanks,

Rachna

Please use plain text.
New Developer
NeelamP
Posts: 1
Registered: ‎01-25-2010
My Device: Blackberry simulator 9000
My Carrier: 9000

Re: Web Format/Layout Issue on 9000 and 9530

Hello,

 

I have created one simple HTML page to test it on Blackberry simulator 9000. But it does not displayed properly (I have to press zoom in to select html components) where as the same page displays properly on blackberry simulator 8300.

Can anyone know workaround for this issue.

Your help is deeply appreciated.

 

Thanks & Regards,

Neelam

Please use plain text.
New Developer
ram_bold
Posts: 10
Registered: ‎12-22-2009
My Device: Bold
My Carrier: Vodafone

Re: Web Format/Layout Issue on 9000 and 9530

hi all,

 

any info how to solve this issue?

 

thanks,

ram

Please use plain text.