Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Visitor
Posts: 1
Registered: ‎01-09-2012
My Device: Blackberry Playbook
Accepted Solution

Web Inspector Porblems

I have been developing on the playbooks OS2.0 beta and had no problems with using the web inspector on the playbook.  I recently downgraded to OS1.0.8.6067 and have found that I cannot access any app remotely.  

I find that when I try to load the debuger page it shows this:

 

  • Open...

 

and when I select the open I get:

 

Broken Web Inspector

 

I am using the '-d' tag when compiling and I am using chrome to access it.  Is there a problem with OS1.0.8 or is it me causing it?  I have gotten in some instances the inital page to say 'AppName' (for what ever the app's name is) but it still leads me to the same broken web inspector. 

Developer
Posts: 51
Registered: ‎10-22-2011
My Device: 9800

Re: Web Inspector Porblems

I only found remote web inspector started working in 2.0.    You can run the browser locally on the playbook to look at it but that isn't as convenient. 

Retired
Posts: 518
Registered: ‎07-18-2011
My Device: Bold

Re: Web Inspector Porblems

There is an issue with newer versions of chrome that they have changed their implementation of web sockets which makes them incompatible with the ones used in our remote web inspector. Can youy try in a different webkit browser?



1.Please resolve your thread by clicking the "Accept as Solution" button below the post which solved your problem!
2. If any post helps you please click the button below the post(s)
Developer
Posts: 51
Registered: ‎10-22-2011
My Device: 9800

Re: Web Inspector Porblems

I stand corrected.   Remote inspector worked from my Mac Safari to both 1.0.8 and 2.0.