Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Member
xtronic
Posts: 1
Registered: ‎03-05-2011
My Device: Not Specified

WebWorks Playbook SDK - Can't get video to play

I can't seem to get any sort of video to play on the playbook simulator. I've tried youtube video, local videos of .mov, .m4v,.avi,.flv, anf .swf formats on different players like jwplayer and flow. I've tried making a page (.html) with JUST the video in it (and standard html tags) and the playbook just doesn't show anything =[

 

Here is an the code for one of the attempts (works in browser just fine, but not the playbook)

 

 

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en">
    <head>    
        <title>AppMobi</title>
        <script src="script/video/jwplayer.js" type="text/javascript"></script>
    </head>
        
    <body>
 
<video id="mediaplayer"
    width="480"
    height="270"
    src="videos/video.mov"
    poster="http://content.bitsontherun.com/thumbs/bkaovAYt-480.jpg">
</video>
<script type="text/javascript">
  jwplayer('mediaplayer').setup({
     'flashplayer': 'script/video/player.swf'
  });
</script>
    </body>
</html>

 

 

I've tried the <object> and <embed> tags as well. Nothing happens, the playbook screen is just blank...

 

Thanks so much for any help!!!

-Jason

Please use plain text.
New Contributor
aghiecool
Posts: 2
Registered: ‎09-17-2010
My Device: 9000

Re: WebWorks Playbook SDK - Can't get video to play

Im having the same issu aswell.

I used jwplayer to embed streaming media on my webserver. It works on browser but when on playbook. player only show blank video.

 

Does playbook have to use built in player/api to play a video. or we can use any flash video player availabale on the net?

Please use plain text.
Developer
praveen_rajan
Posts: 163
Registered: ‎05-06-2011
My Device: Playbook

Re: WebWorks Playbook SDK - Can't get video to play

Please see this link to view details about HTML5 video API for PlayBook

 

http://www.blackberry.com/developers/docs/webworks/api/HTMLVideoElement.html

Please use plain text.
Contributor
hababut
Posts: 41
Registered: ‎07-21-2011
My Device: Superberry

Re: WebWorks Playbook SDK - Can't get video to play

Also, make sure that you whitelist the URLs that you're pulling the video from. Otherwise will not be able to load.
----------------------------------------------------------------------------------------------
I kode for cudos! Or was it the other way around?
Please use plain text.
Developer
SumiGhosh
Posts: 435
Registered: ‎09-20-2011
My Device: Z10 LE, Playbook, DevAlpha C, 9900, 9380

Re: WebWorks Playbook SDK - Can't get video to play

Hi guys...

        What i found is in some documentation they have said that there are no codecs distributed
with the simulator so it cannot play audio/video for playbook and smartphone version 7.0

Please use plain text.