Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
zubair01
Posts: 70
Registered: ‎04-08-2011
My Device: BB 4 and BB 5.0

Webworks Issues

[ Edited ]

Hi! I have local images in my project but its rendering time is very slow, as if they are fetched from somewhere else, do we need to define something in config.xml to make them load faster?

 

In OS 5 the footer disappears as the content load and it never come back.

 

 In OS 6 Torch device, the app load first time but as I close it and try to reopen it white screen appears and app never load.

 

Loading Spinner is also not spinning properly.

 

Any possible solution?

 

Here is my config.xml

 <?xml version="1.0" encoding="utf-8"?> 
 <widget xmlns=" http://www.w3.org/ns/widgets"
         xmlns:rim="http://www.blackberry.com/ns/widgets"
         version="2.0"
         rim:header="RIM-Widget: rim/widget">

 <author href="http://www.abc.com/"
         rim:copyright="Copyright 1998-2011 abc">abc</author>
   <rim:navigation mode="focus" />
   <name>abc</name>

   <description>
     abc
   </description>


  
   <icon src="icons/appicon.png"/>
   <icon src="icons/appfocus.png" rim:hover="true"/>

   <content src="index.htm">
   </content>
  
    <feature id="blackberry.ui.event" required="true" version="1.0.0.0" />
    <feature id="blackberry.system" required="true" version="1.0.0.0" />
    <feature id="blackberry.ui.menu" required="true" version="1.0.0.0" />
    <feature id="blackberry.ui.dialog"/>
  
   <access uri="*" subdomains="true"/>
  

   <license>
     Example license
     Copyright (c) 2011 My Corp.
     THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
     EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
     MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
     NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
     BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
     ACTION OF CONTRACT, INSULT OR OTHERWISE, ARISING FROM, OUT OF OR IN
     CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
     SOFTWARE.
   </license>

 </widget>

 

 

 

thanks

Retired
jeffheifetz
Posts: 518
Registered: ‎07-18-2011
My Device: Bold

Re: Webworks Issues

Hi ,

 

If you want to load Tim's spinner API, you will need to add the feature ID for it - <feature id="blackberry.ui.Spinner" /> to your config file.

 

I haven't heard any other issues about 5.0 footers, my guess is its some piece of JS that isn't fully supported on 5.0. If you try to generecize the code and give me a bundle version I can confirm if its broken for me as well.

 

As per the 6.0 white screen, I've also never heard anything along these lines. Are you building with the newest SDK? Is it possible its some sort of caching issue, if you disable caching does it still happen?



1.Please resolve your thread by clicking the "Accept as Solution" button below the post which solved your problem!
2. If any post helps you please click the button below the post(s)