Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
Posts: 4
Registered: ‎08-05-2011
My Device: Developer
My Carrier: none

Webworks javascript extensions working on simulator, not on devices

[ Edited ]

Hi,

 

I'm developing an application that uses HTML / JQuery mobile for the ui and webworks javscript extensions to control the backend java code and I'm having trouble getting the extensions to work on any blackberry phone device.

 

Everything works fine in my 9550 simulator, but when I sign the application and load it onto the phone(bold 9700, OS6 bundle 1879) anything to do with a javascript extension basically just doesn't work. Any button that calls a javascript extension is unresponsive, and calls to javascript extensions from jQuery events do nothing.

 

Another developer I'm working with is using a bold 9780 with OS6 bundle 863, and when a javascript extension is called on his phone the application just changes to a blank white screen and does nothing.

 

Any ideas on what's causing this?

 

Thanks in advance,

dd

New Developer
Posts: 4
Registered: ‎08-05-2011
My Device: Developer
My Carrier: none

Re: Webworks javascript extensions working on simulator, not on devices

if anyone has any ideas, anything at all, I would really appreciate it as I'm under a pretty tight deadline with this.

 

dd

Retired
Posts: 518
Registered: ‎07-18-2011
My Device: Bold
My Carrier: Rogers

Re: Webworks javascript extensions working on simulator, not on devices

Hi  ,

 

Its bizarre that the app should act so differently on device vs sim. I'm just wondering if you've tried it on a 6.0  sim as well and its worked fine. Perhaps its a 5.0 vs 6.0 issue. To download a new sim you can check out this link http://us.blackberry.com/developers/resources/simulators.jsp

 

Are you using any custom extensions or just the ones built into webworks?



1.Please resolve your thread by clicking the "Accept as Solution" button below the post which solved your problem!
2. If any post helps you please click the button below the post(s)