Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
vipintomer
Posts: 41
Registered: ‎05-03-2012
My Device: 9800 torch

Re: White screen flashes between page loads

As i am using sencha touch than how can i fix this white screen issue

please give an example to load html page.

 

Thanks

Vipin Tomer

Please use plain text.
Developer
nunodonato
Posts: 313
Registered: ‎03-28-2012
My Device: Curve 9360, Playbook, BB10 Dev Alpha

Re: White screen flashes between page loads

Probably you should ask that in Sencha support forums :smileyhappy:

Nuno
theBBthing.wordpress.com - my BlackBerry development blog: news, tips and tutorials
bitoutsidethebox.com - re-imagining digital solutions


Please use plain text.
Retired
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: White screen flashes between page loads

It would be along the same lines.. don't change the URL of the page.  Dynamically create your new UI and load it into the existing page.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
Contributor
vipintomer
Posts: 41
Registered: ‎05-03-2012
My Device: 9800 torch

Re: White screen flashes between page loads

Thanks

 

But what about the sencha. Can i do this using sencha

 

 

Vipin

Please use plain text.
Retired
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: White screen flashes between page loads

As far as I know... the "how do I do this", you're going to have to find someone who is familiar with Sencha to answer that question.  I would suggest starting with the Sencha touch forums.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
New Contributor
darmie
Posts: 3
Registered: ‎10-07-2013
My Device: Bold5

Re: White screen flashes between page loads

Hi Tim, I setup the backgroundColor of my loadingScreen, i still get a white flicker when page loads. 

 

<rim:loadingScreen backgroundColor="#2780BE"
backgroundImage="bg.png"
onFirstLaunch="true"
onLocalPageLoad="true">
<rim:transitionEffect type="fadeIn" direction="left" />
</rim:loadingScreen>

Please use plain text.