Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
Posts: 2
Registered: ‎03-08-2010
My Device: Not Specified

Widgest Problem

Hi ...

 

This is Message because i have developing application with webservice.

 

After sign application i add application in blackberry 9800.

 

for one day it work fine after that the webservice call make error message as in responce

 

http://xxxxxx.xxxxxxxxxxx.com/BB/blackberry.asmx

 

Could not select proper Transport Descriptor for http://xxxxxxx.xxxxxxxxxx.com/BB/Blackberry

 

 

so i don't understand what happens to this.

 

 

as domain service add in config.xml

 

as 

 

 

  <access uri="http://xxxxxxx.xxxxxxxx.com" subdomains="true" />

 

Satish Kayada
Softwere Developer (Blackberry)
Shree Ramkrishna Export
Retired
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Widgest Problem

That error tells me that the WebWorks application could not connect to the given resource.

 

Can you confirm that the URL you are specifying in your WebService call has the ".asmx" text at the end of it?  The error message you provided suggests that the HTTP request is being made to "http://xxxxxxx.xxxxxxxxxx.com/BB/Blackberry" and not "http://xxxxxxx.xxxxxxxxxx.com/BB/Blackberry.asmx"

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.