Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
Posts: 61
Registered: ‎04-02-2008
My Device: Not Specified
Accepted Solution

Widgets on pre 5.0 devices

 

   At a high level, what are the OS 5.0 features that are required that are not available to devices running OS < 5.0?  In other words, is there going to be any way to run widgets on older devices?

 

   I like the new widget development method, but it will be a long, long time before OS 5.0 will be in widespread use.  Once the new OS 5.0 is released for older devices, it takes a long time for the carriers to make them available, and it takes even longer for companies/end users to actually upgrade the older devices (if at all).

 

Fred

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: Widgets on pre 5.0 devices

Hi Fred,

 

There are two main items that are on 5.0 that make widgets possible.   

 1) BrowserField2 that allows for Custom JavaScript extensions

 2) The BlackBerry Widget JavaScript API's that are part of the operating system

 

So without these two items on older operating systems, widgets cannot work. 

 

Update and spreading of the new operating system does take time.  So this is a technology that is something we are wanting to build on and also provide a new means for development on the new smartphones as they come out. 

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Developer
Posts: 61
Registered: ‎04-02-2008
My Device: Not Specified

Re: Widgets on pre 5.0 devices

Hi Tim,

 

   Thanks for the answers.  Looking forward to seeing you again at the Developer's Conference.

 

Fred