Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
Posts: 7
Registered: ‎11-23-2009
My Device: Not Specified

XML Parser errors after BES 4.1.7 upgrade

We recently upgraded our corporate BES from 4.0.6 to 4.1.7.  Immediately afterwards *some* Blackberry device models (like the 8830) started getting XML Parser errors on our internal web pages that were displaying fine prior to the upgrade (and other devices like the 8703e had no issues).  Switching the BB browser to any other emulation mode besides Blackberry would resolve the issue, but I determined the root cause was that code which did not confirm exactly to the XHTML specifications suddenly choked on those problematic devices.  Meaning all "< br >" tags had to be changed to "< br  />", etc.  Anyone else experience something similar or know if this can be controlled by some BES setting?

Developer
Posts: 395
Registered: ‎12-18-2008
My Device: BlackBerry Torch 9800
My Carrier: AT&T

Re: XML Parser errors after BES 4.1.7 upgrade

There's really no emulation mode on the BlackBerry Browser. There's only one browser rendering engine, when you change Browser Emulation - the ONLY thing that happens is that the value in the HTTP User-Agent header value is changed to tell the web server the browser is a different browser.

 

Nothing actually changes in the browser - all that happens is that any server side code that detectes the browser and delivers different content would then deliver different content to the device.

 

What that means then is that your server is delivering different HTML content when you change the browser's Identity.  Take a look at browser source code in the different modes and you'll see what's different. To view browser source, hold down the alt key and type 'RBVS' (stands for RIM BlackBerry View Source I think). When you release the alt key, the page source will open.  Check to see if there's any difference and if there is, it's being done by the server, not the bb.

 

Also, what's your page's doctype set to?

 

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

 

If it's XHTML as shown above, then you do have to make your <br /> tags CML compliant - it's part of the spec.