Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
newone
Posts: 43
Registered: ‎02-05-2010
My Device: 8900
My Carrier: don't know

app don't open after signing

Hello everyone,

 

my problem is that I sign my app and than I install it on the device. But when I click on the icon to open it, nothing happens. I can click and click and click, but there is nothing.

 

What can I do?

 

thanx

newone

Please use plain text.
BlackBerry Development Advisor
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: app don't open after signing

[ Edited ]

Hi newone,

 

A few questions...

 

Can you post up the OS version number where you are seeing the problem?  

 

Also, is the initial page of your WebWorks/widget pointing to a remote website?

 

Can you post the version of the BlackBerry Widget SDK you used to build your application with?

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
Developer
newone
Posts: 43
Registered: ‎02-05-2010
My Device: 8900
My Carrier: don't know

Re: app don't open after signing

Hi Tim,

 

1. the OS is 5.0.2.0

2. No I can see only the icon in the download folder and with a click on it, there is nothing happens

3. I forgot which version it is. And I don't know where I can find it.

 

thanx

newone

Please use plain text.
Developer
jmace
Posts: 482
Registered: ‎10-24-2008
My Device: 9300
My Carrier: AT&T

Re: app don't open after signing

newone,

 

if you go into the control panel and "add/remove programs" or "programs and features" (depending on the desktop OS)... you'll get a list of the programs installed on your PC. 

 

You'll find an entry for the BlackBerry Widget SDK that will have a version number at the tail of the name.

 

 

mine is currently BlackBerry Widget SDK v1.0.0.126 

 

Upgrading soon though to the new v 1.5

_________________________________________
www.jasonmace.com/blackberry
Please use plain text.
Developer
newone
Posts: 43
Registered: ‎02-05-2010
My Device: 8900
My Carrier: don't know

Re: app don't open after signing

jmace,

 

thank you. So my version is 1.0.0.126.

 

Is there now more help on my  questiion?

 

thanx

newone

Please use plain text.
New Contributor
yleblond
Posts: 3
Registered: ‎03-18-2011
My Device: Torch - developer
My Carrier: developer

Re: app don't open after signing

Hi,

 

I have the same problem, when I test in the simulator is ok. But when I sign my app and than I install it on the device it doesn't start, I click on the icon of the app and there is nothing.

 

I installed the app on my device with 2 methods :

  • BlackBerry Desktop with .alx
  • download from a website with .jad

The result is the same!

 

Since your last comment have you resolved your problem?

 

thx

yohan

Please use plain text.
BlackBerry Development Advisor
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: app don't open after signing

Is your start page local or remote?

 

Do you have logic running on your onload of the start page?

 

Can you post up the Model number and OS version that you are using?

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
New Contributor
yleblond
Posts: 3
Registered: ‎03-18-2011
My Device: Torch - developer
My Carrier: developer

Re: app don't open after signing

Tim,

 

In first time thx for your help.

 

My start page is in local, after there are ajax requests to get data. The ajax request call internal pages ( hosted on our intranet server), do I need to configure a proxy in my app?

 

My BB is a Torch 9800 and the OS version is 6.0.0.246 (bundle 695, Plateform 6.4.0.105)

 

Yohan

Please use plain text.
BlackBerry Development Advisor
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: app don't open after signing

If you aren't performing your AJAX call onload will the application start?  Also are you performing synchronous or asynchronous AJAX calls.. If the call is synchonous it may be blocking the loading of the page/app

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
New Contributor
yleblond
Posts: 3
Registered: ‎03-18-2011
My Device: Torch - developer
My Carrier: developer

Re: app don't open after signing

I changed my request ajax to asynchronous but there is no change, the result is the same.

 

I think it is an other problem because I remove all html code on my start page (index.html), just add the sentence 'hello world', in the simulator it's ok but when I sign the app and push on my device I have already the same problem. I click on the icon of the app and there is nothing.

 

Very strange

Please use plain text.