Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
Posts: 17
Registered: ‎01-07-2010
My Device: Not Specified

error load application

[ Edited ]

hi all!!

 

I've done a simple helloworld widget application with Visual studio.

 

It run great on 9500 simulator but give this error: "ERROR STARTING helloWorld: module_net_rim_bb_browser_field2.api NOT FOUND", on 8900 simulator.

 

So I've tried to install the .jar on a real device (8310)  but I failed. The error message gave to me is:  "907 invalidator jar descriptor missing required attribut: midlet_1"

 

Can you help me?? 

 

Thanks

 

 

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: error load application

Hi There,

 

Which version of the BlackBerry Operating System do you have on the 8900 simulator?  BlackBerry Widgets require the 5.0 operating system.

 

Also I don't believe the 8310 supports the 5.0 operating system.  But when you are loading an application onto a physical device you need to use one of the following methods:

- The desktop manager via a USB cable using the *.cod files and the *.alx file

- Load the application over the air using the *.cod files and the *.jad file

- load the *.cod files via the javaloader command line via the USB cable

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter