Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
uranetz
Posts: 2
Registered: ‎09-20-2010
My Device: Not Specified

error with intall WDP for eclipse

Hi,

I'll try to install BlackBerry Web Development Plug-in for Eclipse like it described at http://na.blackberry.com/eng/developers/browserdev/eclipseupdate.jsp 

but I have problems: 

1) if use eclipse classic with First step when i choose components :

 

 

Cannot complete the install because of a conflicting dependency.
  Software being installed: Eclipse Web Developer Tools 3.1.1.v200908120400-7R77FSpEVw2xXR0CtKvX6bG6a2qU (org.eclipse.wst.web_ui.feature.feature.group 3.1.1.v200908120400-7R77FSpEVw2xXR0CtKvX6bG6a2qU)
  Software currently installed: Eclipse SDK 3.6.0.I20100608-0911 (org.eclipse.sdk.ide 3.6.0.I20100608-0911)
  Only one of the following can be installed at once: 
    Equinox Provisioning UI Support 2.0.0.v20100518 (org.eclipse.equinox.p2.ui 2.0.0.v20100518)
    Equinox Provisioning UI Support 1.0.101.R35x_v20090819 (org.eclipse.equinox.p2.ui 1.0.101.R35x_v20090819)
  Cannot satisfy dependency:
    From: Equinox p2 Provisioning 2.0.0.v20100503-897HFZ-FdHjO2NQo0sD_Nt (org.eclipse.equinox.p2.user.ui.feature.group 2.0.0.v20100503-897HFZ-FdHjO2NQo0sD_Nt)
    To: org.eclipse.equinox.p2.ui [2.0.0.v20100518]
  Cannot satisfy dependency:
    From: Eclipse SDK 3.6.0.I20100608-0911 (org.eclipse.sdk.ide 3.6.0.I20100608-0911)
    To: org.eclipse.equinox.p2.user.ui.feature.group [2.0.0.v20100503-897HFZ-FdHjO2NQo0sD_Nt]
  Cannot satisfy dependency:
    From: org.eclipse.wst.server.discovery 1.0.1.v20090812b
    To: bundle org.eclipse.equinox.p2.ui [1.0.100,2.0.0)
  Cannot satisfy dependency:
    From: WST Server UI 3.1.1.v20090727b-7B3DOAtJZOyxlIZDDYPO4256 (org.eclipse.wst.server_ui.feature.feature.group 3.1.1.v20090727b-7B3DOAtJZOyxlIZDDYPO4256)
    To: org.eclipse.wst.server.discovery [1.0.1.v20090812b]
  Cannot satisfy dependency:
    From: Eclipse Web Developer Tools 3.1.1.v200908120400-7R77FSpEVw2xXR0CtKvX6bG6a2qU (org.eclipse.wst.web_ui.feature.feature.group 3.1.1.v200908120400-7R77FSpEVw2xXR0CtKvX6bG6a2qU)
    To: org.eclipse.wst.server_ui.feature.feature.group [3.1.1.v20090727b-7B3DOAtJZOyxlIZDDYPO4256]

 

Cannot complete the install because of a conflicting dependency.  Software being installed: Eclipse Web Developer Tools 3.1.1.v200908120400-7R77FSpEVw2xXR0CtKvX6bG6a2qU (org.eclipse.wst.web_ui.feature.feature.group 3.1.1.v200908120400-7R77FSpEVw2xXR0CtKvX6bG6a2qU)  Software currently installed: Eclipse SDK 3.6.0.I20100608-0911 (org.eclipse.sdk.ide 3.6.0.I20100608-0911)  

Only one of the following can be installed at once:     Equinox Provisioning UI Support 2.0.0.v20100518 (org.eclipse.equinox.p2.ui 2.0.0.v20100518)    Equinox Provisioning UI Support 1.0.101.R35x_v20090819 (org.eclipse.equinox.p2.ui 1.0.101.R35x_v20090819)  

Cannot satisfy dependency:    From: Equinox p2 Provisioning 2.0.0.v20100503-897HFZ-FdHjO2NQo0sD_Nt (org.eclipse.equinox.p2.user.ui.feature.group 2.0.0.v20100503-897HFZ-FdHjO2NQo0sD_Nt)    To: org.eclipse.equinox.p2.ui [2.0.0.v20100518]

  Cannot satisfy dependency:    From: Eclipse SDK 3.6.0.I20100608-0911 (org.eclipse.sdk.ide 3.6.0.I20100608-0911)    To: org.eclipse.equinox.p2.user.ui.feature.group [2.0.0.v20100503-897HFZ-FdHjO2NQo0sD_Nt] 

 Cannot satisfy dependency:    From: org.eclipse.wst.server.discovery 1.0.1.v20090812b    To: bundle org.eclipse.equinox.p2.ui [1.0.100,2.0.0) 

 Cannot satisfy dependency:    From: WST Server UI 3.1.1.v20090727b-7B3DOAtJZOyxlIZDDYPO4256 (org.eclipse.wst.server_ui.feature.feature.group 3.1.1.v20090727b-7B3DOAtJZOyxlIZDDYPO4256)    To: org.eclipse.wst.server.discovery [1.0.1.v20090812b]

  Cannot satisfy dependency:    From: Eclipse Web Developer Tools 3.1.1.v200908120400-7R77FSpEVw2xXR0CtKvX6bG6a2qU (org.eclipse.wst.web_ui.feature.feature.group 3.1.1.v200908120400-7R77FSpEVw2xXR0CtKvX6bG6a2qU)    To: org.eclipse.wst.server_ui.feature.feature.group [3.1.1.v20090727b-7B3DOAtJZOyxlIZDDYPO4256]

 

2) if use eclipse for java ee developers with 3 step: 

 

 

Cannot complete the install because of a conflicting dependency.

  Software being installed: BlackBerry Web Plug-in 2.0.0.201003191451-33 (net.rim.browser.tools.feature.feature.group 2.0.0.201003191451-33)

  Software currently installed: Eclipse IDE for Java EE Developers 1.3.0.20100617-0521 (epp.package.jee 1.3.0.20100617-0521)

  Only one of the following can be installed at once: 

    Help System Core 3.5.0.v20100524 (org.eclipse.help 3.5.0.v20100524)

    Help System Core 3.4.1.v20090805_35x (org.eclipse.help 3.4.1.v20090805_35x)

  Cannot satisfy dependency:

    From: Eclipse IDE for Java EE Developers 1.3.0.20100617-0521 (epp.package.jee 1.3.0.20100617-0521)

    To: org.eclipse.epp.package.jee.feature.feature.group [1.3.0.20100617-0521]

  Cannot satisfy dependency:

    From: BlackBerry Web Plug-in Documentation 2.0.0.201003191451-33 (net.rim.browser.doc 2.0.0.201003191451-33)

    To: bundle org.eclipse.help [3.4.0,3.5.0)

  Cannot satisfy dependency:

    From: BlackBerry Web Plug-in 2.0.0.201003191451-33 (net.rim.browser.tools.feature.feature.group 2.0.0.201003191451-33)

    To: net.rim.browser.doc [2.0.0.201003191451-33]

  Cannot satisfy dependency:

    From: Java EE IDE Feature 1.3.0.20100617-0521 (org.eclipse.epp.package.jee.feature.feature.group 1.3.0.20100617-0521)

    To: org.eclipse.platform.feature.group [3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY]

  Cannot satisfy dependency:

    From: Eclipse Platform 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY (org.eclipse.platform.feature.group 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY)

    To: org.eclipse.rcp.feature.group [3.6.0.v20100519-9OArFKvFtsd7WLUKh-DcYTS]

  Cannot satisfy dependency:

    From: Eclipse RCP 3.6.0.v20100519-9OArFKvFtsd7WLUKh-DcYTS (org.eclipse.rcp.feature.group 3.6.0.v20100519-9OArFKvFtsd7WLUKh-DcYTS)

    To: org.eclipse.help [3.5.0.v20100524]

 

 

What should i do? 

Please use plain text.
New Contributor
uranetz
Posts: 2
Registered: ‎09-20-2010
My Device: Not Specified

Re: error with intall WDP for eclipse

pass first step:

install eclipse for javascript developers, then intall Java EE DT plugin

now i'm stuck at step 3:

 

Cannot complete the install because one or more required items could not be found.
  Software being installed: BlackBerry Web Plug-in 2.0.0.201003191451-33 (net.rim.browser.tools.feature.feature.group 2.0.0.201003191451-33)
  Missing requirement: BlackBerry Web Plug-in 2.0.0.201003191451-33 (net.rim.browser.tools.feature.feature.group 2.0.0.201003191451-33) requires 'org.eclipse.ui.workbench [3.5.0,3.6.0)' but it could not be found

Cannot complete the install because one or more required items could not be found.  Software being installed: BlackBerry Web Plug-in 2.0.0.201003191451-33 (net.rim.browser.tools.feature.feature.group 2.0.0.201003191451-33)  Missing requirement: BlackBerry Web Plug-in 2.0.0.201003191451-33 (net.rim.browser.tools.feature.feature.group 2.0.0.201003191451-33) requires 'org.eclipse.ui.workbench [3.5.0,3.6.0)' but it could not be found

 

Please use plain text.
New Contributor
marloncs
Posts: 6
Registered: ‎10-11-2010
My Device: BBerry Curve
My Carrier: Claro

Re: error with intall WDP for eclipse

[ Edited ]

hi...

 

i was the same problem, but i fidex that with this process....

 

u need download first the BlackBerry Web Plug-in for Eclipse version 2.0 (516Mb aprox) from: 

 

http://us.blackberry.com/developers/browserdev/eclipseplugin.jsp

 

in BlackBerry Web Plug-in for Eclipse v2.5 (for Eclipse 3.6) section 2.

 

When you finish to install this one, update eclipse with:

 Eclipse Java EE Developer ToolsEclipse Web Developer ToolsJavaScript Developer Tools

 

see the installation instructions, only the first section (point a, b, c...... g) from: 

http://us.blackberry.com/developers/browserdev/eclipseupdate.jsp

 

sometimes,  BlackBerry Web Plug-in for Eclipse version 2.0 have the last versions for   Eclipse Java EE Developer ToolsEclipse Web Developer ToolsJavaScript Developer Tools and dont need to update.

 

ok.... now.... is time to work =)

 

- Mark
Blackberry Developer Group Manager - Panamá

marloncs@gmail.com

Please use plain text.