Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
chrishill
Posts: 3
Registered: ‎05-25-2012
My Device: 9800 torch
Accepted Solution

getting 400 errors on application

[ Edited ]

i working on a application where a user submits a image to a server along with some text data and the server then stores that information. I having problems when i click the submit button it goes to the next page which is a list of everything that is submitted to the server and the item that just was being submitted is showing it in submitting status then after many minutes of waiting  i get a 400:error. I made sure my urls are pointing to the right location as well as the right service and i am not share what the cause would be any help would be greatly appreciated

BlackBerry Development Advisor
twindsor
Posts: 832
Registered: ‎07-15-2008
My Device: Passport
My Carrier: Bell

Re: getting 400 errors on application

I really don't know where to start to help you here. What code are you using? Server? OS? Device? What's in the logs?

 

There's a lot of missing information for someone to come in and help you with it.

Tim Windsor
Open Source Technical Lead
New Contributor
chrishill
Posts: 3
Registered: ‎05-25-2012
My Device: 9800 torch

Re: getting 400 errors on application

we useing c# for the service on the server and we are useing javascript and html as well as jquery mobile on the device our problem hapens with all devices.  windows 7 on the server and  windows 7 on the simulators as well. 

 

            getExpenseReceipt: function (id, onItemProcessed) {
                if (typeof onItemProcessed == 'function')
                    expenseService.Utility.ajaxGet(serviceUrl + '/GetExpenseReceipt/' + id + wifi, onItemProcessed); 
            },

is a exzample of one of the scripts that makes a request to the server  

 

BlackBerry Development Advisor
twindsor
Posts: 832
Registered: ‎07-15-2008
My Device: Passport
My Carrier: Bell

Re: getting 400 errors on application

What is the actual URL that the AJAX call uses?

 

Can you set your eventlog to debug level and review it? There's information about the eventlog here: 

http://supportforums.blackberry.com/t5/Java-Development/What-is-the-Event-Log/ta-p/446875

 

We should be able to see the actual connection and the results if you can attach the log or review it yourself.

Tim Windsor
Open Source Technical Lead
New Contributor
chrishill
Posts: 3
Registered: ‎05-25-2012
My Device: 9800 torch

Re: getting 400 errors on application

[ Edited ]

I have acully fixed this issue today turns out it was data being sent to the server the server whould check to see if it was base64 data and return a error based on that and turned out it was sending a file url to the server whic was not what the server whanted. Thank you everyone for your help.