Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
Posts: 21
Registered: ‎10-28-2011
My Device: Bold 9700
Accepted Solution

:hover problem in Webworks 2.3

In Webworks 2.2, :hover was working fine but after I compiling in 2.3 version, :hover became a problem in my apps.

 

Note: I'm using Webworks 2.3.0.9, OS 5.0 in 8520 (simulator)

 

Thanks..

Developer
Posts: 172
Registered: ‎05-01-2010
My Device: Z10

Re: :hover problem in Webworks 2.3

[ Edited ]

Hi,

 

same for me. The navigation mode is not working anymore. I am using x-blackberry-focusable="true" to determine where it should be able to navigate.

 

update: apparently its not supported anymore. we need to use onmouseover and onmouseout



----------------------------------------------------------
find my widgets -> http://blackberry.itbert.de
Contributor
Posts: 21
Registered: ‎10-28-2011
My Device: Bold 9700

Re: :hover problem in Webworks 2.3

https://github.com/blackberry/WebWorks/issues/49

 

GREAT! :hover won't be supported!

Trusted Contributor
Posts: 152
Registered: ‎02-12-2011
My Device: Not Specified

Re: :hover problem in Webworks 2.3

another reason why android and iphone are the best when it comes to this...utter failure

Developer
Posts: 172
Registered: ‎05-01-2010
My Device: Z10

Re: :hover problem in Webworks 2.3

nice example can be found here: http://labs.adobe.com/technologies/spry/articles/best_practices/separating_behavior.html

 

its possible to re-use your old classes!

There just should be more communication from RIM - not just "we removed it and find your own best working solution"...



----------------------------------------------------------
find my widgets -> http://blackberry.itbert.de